0

I recently switched to Cinnamon, everything works fine other than the fact that I could not connect to the wifi in my university because of I cannot choose the certificate. Here are images of what is going on.

http://postimg.org/image/76xzleqzj/

As you can see, all the certificate are inside the folder but Network Manager only recognize one of them and it is not the one I need. I tried to hardcoded it in the /etc/NetworkManager/system-connections file, I would load forever but not able to connect. Then in the network connection GUI, i tried to enter the location of the file. But afterward, I could not save the file because the save button is disabled.

http://postimg.org/image/jckcihou9/

Other than this issue, everything is working perfectly, I can connect to normal wifi and do whatever I need. It is just the University Wifi Could someone please help me with this issue?

0

I had the same issue. I fixed it by running:

trust extract-compat

as root.

source: https://www.archlinux.org/news/ca-certificates-update/

EDIT:

In order to then connect to the eduroam network at my university, I had to go into the file:

/etc/NetworkManager/system-connections/my-network

And add the line:

system-ca-certs=false

to the section with heading:

[802-1x]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.