1

I downloaded some .vim color scheme files in github and moved them by

sudo mv ~.vim /usr/share/vim/vim73/colors

then I wrote

colorscheme ~.vim

in vimrc. The original schemes already existed, are adjusted very well, however, my downloaded ~.vim files are not adjusted. just black and white. Why this happened and how can I solve it?

0

You should put your colorsscheme in your local vim settings =>

Usually => ~/.vim/colors

For instance :

sudo mv Monokai.vim ~/.vim/colors

And add to your ~/.vimrc

colorscheme Monokai

(without the .vim extension)

  • I solved it, but thanks anyway I confused that there's no colors folder in .vim – M.Yoon Feb 25 '15 at 13:09
0

Oh I solved it. The vim73 folder has runtime files so it is never recommended to edit them.

What I confused is there's no colors folder in ~/.vim .

However, when I make the colors folder by mkdir colors, and move the ~.vim files in here, it is solved perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.