2

Using Windows Remote Desktop (that comes with Windows 8):

ctrl+alt+end is bringing up the dialog for the first computer I remote into, but I need to bring it up for the 2nd computer

my computer > computerA > computerB

so that I can change computerB's password.

I cannot RDP into computerB directly, as it is heavily firewalled.

5
  • Thiese Remote Desktops usually have functions like send ctrl-alt-del and other.
    – ott--
    Feb 26 '15 at 16:29
  • What RDC client are you using?
    – Ramhound
    Feb 26 '15 at 16:30
  • Remote Desktop Connection within windows 8
    – NibblyPig
    Feb 26 '15 at 16:32
  • You can also do this. Feel free to update your question to reflect which client your using.
    – Ramhound
    Feb 26 '15 at 16:36
  • Ta, have updated it. Hopefully has a better title than the other one, and the solution doesn't require any extra software
    – NibblyPig
    Feb 26 '15 at 16:39
3

Have found a workaround:

Press ctrl+alt on the physical keyboard, and using the onscreen keyboard on the computer you wish to bring the dialog up for, press the Delete key using the mouse.

Any other combination doesn't seem to work.

0

Here is an alternative. This worked for me in a slightly different and more complicated setup (connecting from a Mac to a Linux server through SSH and then from the Linux server to a Windows Server 2016 server through Remote desktop protocol using the rdesktop Linux RDP command line client). (In addition, the virtual keyboard did not work at all on the windows server).

In Windows:

  1. Click Start menu
  2. Click in the search bar
  3. Type "powershell"
  4. In the search results, click "powershell.exe"
  5. In the PowerShell shell that opens, type the following:

    Powershell -noprofile -nologo -noninteractive -command "(new-object -ComObject 
    shell.application).WindowsSecurity()"
    

If PowerShell is not available, instead search for "cmd.exe" and in the cmd prompt, type:

explorer shell:::{2559a1f2-21d7-11d4-bdaf-00c04f60b9f0}

Taken from: https://social.technet.microsoft.com/Forums/ie/en-US/9c2ea402-087a-40a0-83de-170b49fdaac5/how-to-change-password-in-rdp-session?forum=winserverTS

Note: if your Mac keyboard layout is not English US, it might be hard to get the {, } characters in cmd.exe. In that case try the following:

  • Change you keyboard layout on your Mac to English US (use System Preferences)
  • In X11's preferences, check "Use system keyboard layout"
  • In Windows, make sure to also set the keyboard layout to English US.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.