On two separate Dell machines, I seem to be having an annoying performance problem when downloading over a single connection. The one I've just tested this all on is a Dell Dimension 3000, XP SP3, P4 2.8GHz, 512MB RAM.

We have a 16 Mbps internet connection, to which all computers connect via WPA Personal-secured wifi. Running a speed test at www.mybroadbandspeed.co.uk indicates a very consistent download speed of ~4900 kbps, from multiple tests over the past week. Never any higher, barely any lower. This happens on both Dells. Firefox 3.5 in all cases. Same result in IE7.
My MacBook on the same network, on its first attempt got 10900 kbps and stays around that level.

However, I went and found a popular torrent on LegalTorrents and started it off on the Dell. It attained a reliable 1+ Mbps download speed (8200 kbps)!

I then tried to use BBC iPlayer to watch a HD stream; straight away it started buffering and gave a warning message that a 3.5 Mbps connection is required. The same show works fine on my MacBook on the same network.

Multiple wifi cards have been tried on the Dell, to no effect. 54 Mbps connection speed to the router is shown with "Excellent" signal.

So it appears the Dells are happy when making multiple TCP connections (BitTorrent), but not a single one (iPlayer, speed test)?

Any ideas about what I can do to fix this?

I have updated the drivers to the latest I could find on the Dell site (was only a minor update; couldn't find any OEM drivers) but still the problem persists. I didn't see anything odd in the driver settings either; power-saving settings were disabled, and the card happily runs at 802.11g speeds.

As I mention above, this seems to be independent of the wireless card being used (whether Dell USB, or a PCI card I put in the machine).

Are there any networking settings in XP that are worth examining, or utilities that I could run?

Update 2:
On Goyuix's suggestion, I tried running the same speed test on the same Dell PC, but using a Ubuntu 9.10 live CD. So I booted into Ubuntu where all the WLAN hardware worked straight away, then I installed Flash and tried the speed test. Got ~11900 kbps download speed.

Rebooted into the usual XP install, made sure there were no extraneous processes running, and with the same test got the usual ~4700 kbps. Tried disabling Windows Firewall to no effect.

As per fluxtendu's answer, I tried the TCP Optimizer software, where I backed up my existing networky/registry settings using the File menu option, then set my desired speed to 16000 kbps, and chose the "Optimal settings" option.

Applying these settings vastly increases the TCP window size and sets the optimal MTU, amongst other networking-related registry keys. You are then prompted for a reboot.

On both Dells, I ran the speed test once again and found that I now got the same performance as my MacBook — in fact slightly faster on one of the machines, attaining over 12000 kbps.


  • 1
    As a curiosity, if you boot a live CD like Ubuntu or Knoppix, how is the wireless performance? – Goyuix Dec 30 '09 at 4:25
  • I just tried a Ubuntu 9.10 live CD, all the hardware worked straight away (awesome) and it got ~11900 kbps on the same speed test. Rebooted into Windows XP a minute later, where it got ~4700 kbps. – Christopher Jan 2 '10 at 1:25

You could try these command-line:

netsh int ip reset [log_file_name]
reset the TCP/IP stack = reset/rewrite the following TCP/IP-related registry keys:

  • SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\
  • SYSTEM\CurrentControlSet\Services\DHCP\Parameters\

(you may need to re-configure your TCP/IP settings after that)

netsh winsock reset
repair winsock It removes all Winsock LSP (Layered Service Providers) previously installed, including the potential malfunctioned LSP that causes loss of network packets transmission failure. So all previously-installed LSPs (antivirus/firewall) may need to be reinstalled

netsh interface reset all
reset all interfaces: 6to4, HTTPSTunnel, ipv4, ipv6, isatap, portproxy, tcp, teredo but I don't know exactly what you risk to do it

netsh references

And you could also try the speddguide.net tcp-optimizer but backup your config before applying changes, and RTFM.

  • Given the general non-explanation of what netsh does and the ever-impenetrable MSDN site, I gave that option a miss. However, I tried the TCP Optimiser software from speedguide.net and, after applying the "optimal" settings and rebooting, both computers now get the 11 Mbps or so they should be. Thanks! – Christopher Jan 4 '10 at 0:26

Can you upgrade the network card driver? Particularly with a driver from the actual OEM (not Dell) - and compare that with the Dell supplied driver? There are also a ton of things that can differ with wireless connections and a few options you can configure in the drivers.

I would check the driver for setting regarding power states and sleep modes. Both of which can have a rather pronounced impact on peak performance.

  • I've tried a non-Dell PCI wireless network adapter rather than the supplied USB one, with the same results. But I will see if I can find an OEM driver and see if I can find any power-related settings. Thanks. – Christopher Dec 28 '09 at 2:18
  • Updating the driver made no difference, nor were there any power settings enabled. I've updated the main post. – Christopher Dec 29 '09 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.