2

I've been thinking about upgrading to Windows 8.1 but wanted to test it first in a virtual pc I made using Oracle VM VirtualBox. I downloaded the Windows 8.1 preview software and so far it works well.

Now I want to test the wifi connection but it seems there is no way to connect to wifi in Windows 8.1 preview software. There is now wifi option in the side bar like there is in Wondows 8 and the only internet connection that shows up even in 'view networks' is an unknown Ethernet connetion that despite me not having plugged in an Ethernet say it's 'Limited'

My question is I'm using Windows 8.1 preview in an Oracle VM VirtualBox virtual pc, how do I connect to wifi?

Anyone who can answer this must be a god among computers

  • Funny you should ask this question now because, at this very moment, I am doing exactly what you are. Running Windows 8.1 Enterprise Evaluation edition in a VirtualBox Virtual Machine. I need to test out all my apps and tools to see if I can live with Windows 8.1. So far so good! My screenshot right now: picpaste.com/Screenshot-win81x64.png – misha256 Feb 27 '15 at 5:51
2

Ah yes, well, VirtualBox doesn't emulate a wireless network device. It only emulates a handful of wired network cards.

In your case, the network card VirtualBox is emulating for your Windows 8.1 Virtual Machine is an Intel PRO/1000 MT Desktop (82540EM) (unless you purposefully changed that setting).

Still, you should be able to get perfect network/internet access in your Virtual Machine. Which means something's not configured right. Shut down your Virtual Machine and go into its Settings. Find the Network settings and make sure you select Bridged Adapter where it says Attached to:

screenshot

Sorry my screenshot is off a Linux machine, however, yours should look similar enough. Click OK to save the changes and start your Virtual Machine. I'll bet that does the trick for you.

  • Goes without saying, make sure your host PC (the PC you're running VirtualBox on) has working network/internet! – misha256 Feb 27 '15 at 5:43
  • God damit! didn't think of that! thankyou for your answer in the nick of time LEGEND! – James. S Feb 27 '15 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.