3

I'm just trying to delete some of the keybindings in Notepad++

In the shortcut mapper, Settings -> Shortcut mapper ..

I don't think I'll use many of these like SCI_WORDPARTLEFT, SCI_SELECTIONDUPLICATE, etc, and I'd like to use the shortcuts for something else.

However the Delete button is greyed out and disabled (the Modify button seems to work). What's going on, is this the intended behaviour? Isn't it possible to delete the shortcuts?

1
  • I was just having the same issue, and then I upgraded Notepad++. I now see a "clear" button, in addition to the "delete" button. The "clear" button did what I wanted.
    – Erhannis
    Jul 29, 2017 at 23:20

2 Answers 2

5

To remove a key binding in Notepad++

  1. Settings -> Shortcut Mapper...
  2. Select the key binding you want to modify, for example some Scintilla command
  3. Click Modify
  4. The Remove box is grayed out, that's fine. Untick all the check boxes (CTRL/ALT/SHIFT)
  5. Choose the first option "None" in the drop down menu for the key combo
  6. Click "Apply"

and the key binding should have vanished...

0
0

Just double click on the shortcut, then a new menu appeared. In this new menu, you can remove the configured shortcut

2
  • This doesn't seem to work with me, E.g. if you go to where it says SCI_WORDPARTLEFT double-click on it, a menu appears and the remove button is greyed out
    – Rob Hoff
    Jun 19, 2015 at 16:00
  • 1
    Use ‚None‘ key instead
    – eckes
    Nov 2, 2017 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.