4

I have deleted the windows efi partition ( not windows ).I have in my system 2 linux distro and 2 efi partitions.

I am trying to fix windows boot following steps like:

here and here.

The problem is , that when I enter the command:

bootrec /fixboot

it shows :

The system cannot find the file specified

I tried to run :

bootrec /rebuildbcd

,so it shows:

Successfully scanned Windows C:\Windows Add installation to boot list?

I answer "Yes" and then it again throws me the previous message.

What can I do about that?

(The "This question may already have an answer here" doesn't help since the /fixboot doesn't work..)

---- UPDATE ----

1) I tried to run : bcdboot c:\Windows and it throws:

BSFSVC Error:Failed to create a new system store

2) I typed active after assign letter = v: but it shows :

The selected disk is not a fixed MBR disk

3) I saw that in the directory : C:\Windows\Boot\EFI\ it has the files : bootmgr.efi , bootmgfw.efi

Should I try there all the commands:

bootrec /fixboot , fixmbr or I may do things worse?

------ UPDATE ---------------------

This post is different from the duplicate one , in that , when I try to run :

bootrec /fixboot , it shows: The system cannot find the file specified

I think I made this clear.Why do you duplicate this post???

--- UPDATE 2 -------------------------

I tried ( i have only 1 disk in my laptop ):

list disk
sel disk 0
list partition
sel partition 2 ( it is an efi partition I have created when I installed linux )
active -> gives message "The selected disk is not a fixed MBR disk" 

I then followed the same procedure:

list vol
sel vol 11
assign letter = v:
exit

Now , when I try: bootrec /fixboot , it shows me the message "No element found"

------UPDATE 3-------------------

I upload screenshots here and here. Disk 0 is my laptop disk. Disk 1 I don't know Disk 2 is the flash drive from which I am running repair disk.

As for the partitions , the 2 and 10 are EFI partitions I generated from the linux distros. So, the volumes are 11 and 12. I tried both.

---------- UPDATE 4 ----------------------------------------------------

I tried :

 bootsect /nt60 ALL /force

but still nothing. When I enter : bootrec /fixboot ,it shows :

element not found.

Also, after this:

Successfully scanned Windows installations.
Total identified Windows installations: 1
[1]  D:\Windows
Add installation to boot list? Yes<Y>/No<N>/All<A>:

I enter Y but I am getting a negative answer ( I don't remember what exactly! ).

The good thing though ,is that now (after updating grub) the windows boot option appeared in my grub menu. But when I select it ,it shows:

The boot configuration data file is missing required information.

File :\BCD Error Code: 0x0000034

I am not sure what to do from now on.

I saw somewhere to try : bcdboot c:\windows but I don't know how to access 'C' drive. Ok, I am doing:

sel disk 0
list vol

and in volumes I can see 'C' listed . But I don't know beyond this.

Also,I tried renaming the BCD file and then rebuild but still the same.

-----UPDATE 5--------------------------

Volume 10 contains:

Bin
Boot
Recovery -> empty
RicaTools -> bootmgr,bootmgr.efi ....
TFR
WinRePartition.ini

Volume 11:

EFI-> manjaro -> grubx64.efi
      BOOT-> BOOTx64.efi
      Microsoft-> Boot -> bootmgfw.efi
                          bootmgr.efi
                          boot.stl
                          MokManager
                          BCD
                          ...

     ->ubuntu-> grubx64.efi,grub.cfg,shimx64.efi

Volume 12:

EFI-> mint ->grubx64.efi
      manjaro-> grubx64.efi

---UPDATE 6------------------

Finally it worked thanks to Christophe!

Just want to note for anyone who has the same problem , that the last command fixboot gave

Element not found

but it didn't matter!

Of course ,finaly,I had to do an update-grub .

  • @Moab:I checked this thread also, it uses the same steps.But my problem is after entering the bootrec /fixboot command , something that is not covered there. – George Feb 28 '15 at 19:17
  • You need to post more info on your exact problem, statements like "I don't remember" are not helpful. The more accurate and detailed info you post the better answers you will get here. – Moab Feb 28 '15 at 20:27
  • @Moab:I will check again the later message about MBR and I will update.The problem though is that I can't execute the command because it can't find the file path.. – George Feb 28 '15 at 20:30
  • Why would you run fixmbr that command is only for MBR partitions. If you have a EFI partition it means your using GPT. – Ramhound Mar 3 '15 at 13:48
  • @Ramhound:I don't know details.Everywhere I can see that.But fixboot doesn't work either – George Mar 3 '15 at 14:13
10
+50

If you have any important data on your computer I advise you to boot on some Windows PE based CD/USB media with a GUI (Hiren's boot CD for example) and connect an external HDD to try backuping your important data.

Try to map the V: letter to the 260MB EFI partition by running the following diskpart commands:

diskpart
select volume 11
assign letter=v:
exit

Then rename the current Windows boot environment folder with the follwing command:

ren V:\EFI\Microsoft\Boot Boot.old

Re-create the Windows boot environment with bcdboot:

bcdboot C:\Windows /s V: /f UEFI

Afterwards, run bootsect which will look through your partitions, find the one with Windows 8 and update its boot code:

bootsect /nt60 ALL /force

Then re-run bootrec which this time should not output any errors :

bootrec /fixmbr

Finally, restart your computer to check if you are able to boot in Windows.

  • Comments are not for extended discussion; this conversation has been moved to chat. – Mokubai Mar 10 '15 at 17:38
  • @Christophe:Yes!!!!!!!!!!!!Excellent!!!!Thanks a lot man!!FInally!Accepted and upvoted!Please ,just edit the bcdboot command.I had to run bcdboot c:\windows /s v: /f uefi. Also,the last command , fixboot gave "element not found" , but it worked anyway!Thanks again – George Mar 10 '15 at 19:38
  • You're welcome, I was glad to help. Oh yes I forgot C:\Windows, I made the edit. If you need to test/work on linux distros you can use virtualization software (VMware Workstation for example) instead of using multiboot. If will allow you to test a lot of stuff without breaking you boot environment. – Chris Mar 10 '15 at 21:47
  • @Christophe:I use only linux the last years.But , since I bought the laptop and it had installed windows , I just wanted to keep it.Now , I don't remember why I deleted in the first place but I thought I wouldn't have a problem loading windows from grub..Anyway, thanks again for your help. – George Mar 11 '15 at 8:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.