0

I am trying to setup websvn but I get an error when I try to access the repository:

svn: E175002: Unexpected HTTP status 405 'Method Not Allowed' on '/svnrep/workspace/history'
svn: E175002: Additional errors:
svn: E175002: PROPFIND request on '/svnrep/workspace/history' failed: 405 Method Not Allowed

I've installed a Debian 8 virtual machine svn.mydomain.com with a static IP address for the purpose. Subversion is working fine and I can access the repository via file:/// on the same machine but not via http. I have the following setup:

root@svn:~# ls /data/svnrep
workspace

root@svn:~# ls /data/svnrep/workspace
README.txt  conf  db  format  hooks  locks

root@svn:~# svn ls file:///data/svnrep/workspace
JavaProjects/
history/
scripts/
websites/

root@svn:~# svn ls http://localhost/svnrep/workspace
svn: E175002: Unexpected HTTP status 405 'Method Not Allowed' on '/workspace'

svn: E175002: Additional errors:
svn: E175002: PROPFIND request on '/workspace' failed: 405 Method Not Allowed

root@svn:~# cat /etc/websvn/svn_deb_conf.inc 
<?php
// please edit /etc/websvn/config.php 
// or use dpkg-reconfigure websvn
$config->parentPath("/data/svnrep");
$config->setEnscriptPath("/usr/bin");
$config->setSedPath("/bin");
$config->useEnscript();
?>

root@svn:~# cat /etc/apache2/mods-enabled/dav_svn.conf | grep -v "#" | grep -v "//"

<Location /svn>

  DAV svn

  SVNPath /data/svnrep/workspace


  AuthType Basic
  AuthName "Subversion Repository"
  AuthUserFile /etc/apache2/dav_svn.passwd


  Require valid-user

</Location>

What am I missing?

1

With your server's config, you should use this URL: http://localhost/svn

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.