1

I have downloaded Mac OS X 64 bit binaries for Elastix and tried to run ./elastix in Mac OS X 10.10 (Yosemite):

$ cd elastix_macosx64_v4.7
$ tree
.
├── CopyrightElastix.txt
├── bin
│   ├── elastix
│   └── transformix
└── lib
    └── libANNlib.dylib
$ cd bin
$ ./elastix
dyld: Library not loaded: libANNlib.dylib
  Referenced from:    
/Downloads/elastix_macosx64_v4.7/bin/./elastix
  Reason: image not found
Trace/BPT trap: 5

The same result appears after running ./transformix.

Is it necessary to do some steps before executing them? Or is something needed in relation to libANNlib.dylib?

0

1 Answer 1

0

In the elastix user manual, it says to add the following lines to .bashrc:

export PATH=folder/bin:$PATH
export LD_LIBRARY_PATH=folder/lib:$LD_LIBRARY_PATH

On MacOS, it's not exactly the same but I got it to work by editing ~/.bash_profile and adding these two lines:

export PATH=folder/bin:$PATH
export DYLD_LIBRARY_PATH=folder/lib:$DYLD_LIBRARY_PATH

where "folder" is the path to the elastix folder.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.