0

I'm having trouble viewing my in-development websites on some remote devices like iPad, Nexus phone, etc. I'm using IIS Express. I've set up the bindings this way:

<site name="WebApplication1" id="7">
    <application path="/" applicationPool="Clr4IntegratedAppPool">
        <virtualDirectory path="/" physicalPath="d:\Programming\WebDotNet\WebApplication1\WebApplication1" />
    </application>
    <bindings>
        <binding protocol="http" bindingInformation="*:64203:localhost" />
        <binding protocol="http" bindingInformation="*:64203:aurora" />
        <binding protocol="http" bindingInformation="*:64203:192.168.1.24" />
    </bindings>
</site>

There are a couple of troubles, though.

The first binding (http://localhost:64203/), naturally, works only on my machine, but it works in every browser.

The second binding (http://aurora:64203/) works partially. It works in IE, Firefox, Opera 12, Safari for Windows (5.1.7). This holds true for my machine and another Windows machine. The URL, however, doesn't work in Chrome, Opera (27), or on any of my mobile devices. On Nexus 5 I've tried both Chrome and Firefox.

The third binding (http://192.168.1.24:64203/) fails to register:

C:\Program Files\IIS Express>iisexpress.exe /site:WebApplication1
Successfully registered URL "http://localhost:64203/" for site "WebApplication1" application "/"
Successfully registered URL "http://aurora:64203/" for site "WebApplication1" application "/"
Failed to register URL "http://192.168.1.24:64203/" for site "WebApplication1" application "/". Error description: The network location cannot be reached. For information about network troubleshooting, see Windows Help. (0x800704d0)

Please help me resolve this issues, as I really need to test my websites on mobile devices.

P.S.: If this might be relevant, my router is Cisco EPC3925 EuroDocsis 3.0 2-PORT Voice Gateway and I've set static IPs internally for most of my machines.

16
  • (1) Is 192.168.1.24 same as localhost? (2) Please post the entire config file, (3) Try to disable the firewall, (4) Try another port than 64203. – harrymc Mar 10 '15 at 7:36
  • (1) Localhost is never the same as an IP. But, yes, when I'm running locally, it's from the same computer as that IP points to. (2) Are there any specific parts that are important, as the config file contains some personal data. (3) Firewall was disabled all the way. If it wouldn't be, how could IE on another PC still get trough? (4) This is just a sample for this question, I've tried with 5 or 6 different projects at least, which means just as many different ports. No difference in how it works. – gligoran Mar 10 '15 at 8:58
  • (1) Don't nitpick, (2) Not if it is free from clutter, (3) Nitpicking again?, (4) I was worried about your using a dynamic port, (5-new) What about using host headers as alternate solution. – harrymc Mar 10 '15 at 11:24
  • (1) Wasn't nitpicking. Using the IP instead of localhost isn't interchangeable even on my dev machine. I'm differentiating, because the problem might have something to do with that. (2) I'll try to clean it up and post it, but it might take a day or two. (3) I played with the firewall and when it was on, it didn't work on the other Windows PC. (4) Nope. VS2013 assigns a (seemingly) random port to each web project. I tried changing it, but it doesn't seem there's an issue with fighting for the port. (5) I'll look into that an report back. Thanks – gligoran Mar 10 '15 at 15:25
  • If you are using VS, sometimes running it once as administrator solves problems. – harrymc Mar 10 '15 at 16:49
0

As far as the *:64203:aurora binding is concerned, your mobile devices need DNS entries mapping aurora to your IP address (I'm assuming 192.168.1.24).

For the *:64203:192.168.1.24 binding, I wasn't able to reproduce the error exactly. I would make sure you are running the command from and elevated (Administrator) command prompt. Also, the error description leads towards a network related error, so make sure that your IP configuration is correct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.