0

I am running FreeBSD 8.4 and have trouble with IPv6.

I can connect to my server from outside, connect locally to my jails. But from the server I cannot connect to the outside world. When I ping6 to ipv6.google.com, it tells me it send xx packets, received 0, 100% loss.

I am not sure in what direction I should search, any advise is appreciated.

(I recently upgraded to 8.4 from 8.1. Since I do not use IPv6 much, I cannot be certain if it worked before, though I am quite sure it did.)

In rc.conf I have this:

ipv6_enable="YES" 
rtsold_enable="YES"
ipv6_defaultrouter="xxxx:yyyy:zzzz::1"
ipv6_ifconfig_em0="xxxx:yyyy:zzzz::2"
ipv6_ifconfig_em0_alias0="xxxx:yyyy:zzzz::106"
ipv6_ifconfig_em0_alias1="xxxx:yyyy:zzzz::107"
ipv6_static_routes="myroute1"
ipv6_route_myroute1="xxxx:yyyy:zzzz::0/64 xxxx:yyyy:zzzz::1"

In resolv.conf:

search lxs.biz
# dns of uplink
nameserver [xxxx:yyyy:zzz::23]
nameserver [xxxx:yyyy:zzz::24]
#openDNS
nameserver [2620:0:ccc::2]
nameserver [2620:0:ccd::2]

output of netstat -rn

Internet6: 
Destination                       Gateway                  Flags      Netif Expire
::/96                             ::1                     UGRS        lo0 => 
default                           xxxx:yyyy:zzzz::1       UGS         em0 
::1                               link#12                 UH          lo0 
::ffff:0.0.0.0/96                 ::1                     UGRS        lo0 
xxxx:yyyy:zzzz::/64               link#5                  U           em0 
xxxx:yyyy:zzzz::2                 link#5                  UHS         lo0 
xxxx:yyyy:zzzz::106               link#5                  UHS         lo0 
xxxx:yyyy:zzzz::107               link#5                  UHS         lo0 
fe80::/10                         ::1                     UGRS        lo0 
fe80::%em0/64                     link#5                  U           em0 
fe80::225:90ff:fe10:7e84%em0      link#5                  UHS         lo0 
fe80::%lo0/64                     link#12                 U           lo0 
fe80::1%lo0                       link#12                 UHS         lo0 
ff01::%em0/32                     fe80::225:90ff:fe10:7e84%em0  U           em0 
ff01::%lo0/32                     ::1                           U           lo0 
ff02::/16                         ::1                           UGRS        lo0 
ff02::%em0/32                     fe80::225:90ff:fe10:7e84%em0  U           em0 
ff02::%lo0/32                     ::1                           U           lo0
  • If you can connect to your server from outside via IPv6, then your routes are probably okay. If your routes are okay and you can't ping ipv6.google.com by name, then your DNS settings may be the problem. Can you ping6 any known public IPv6 address by address, not name? – Spiff Mar 2 '15 at 22:21
  • It's difficult to tell whether your setup is correct since you have obfuscated everything useful. But, check the actual IPv6 address of your gateway with ping6 -c 1 -I em0 ff02::2. The gateway will respond to the ping from its IPv6 address, if it is up. – Michael Hampton Mar 3 '15 at 0:23
  • The gateway does respond to ping. – Lexib0y Mar 3 '15 at 9:33
  • Actualy, I cannot connect to ::2, I was mistaken. All the aliases are reachable though. – Lexib0y Mar 3 '15 at 9:34
  • I am going to take a fresh look at the problem. I need to do some extra testing from inside the jails that run on the aliases as well. – Lexib0y Mar 3 '15 at 9:35
0

Replacing the ::2 address in the rc.conf with ::100, and than reboot once more did the trick.

I also removed the line

rtsold_enable="YES"

I removed it because I added it while I already had the problem.

This is now my rc.conf:

ipv6_enable="YES" 
ipv6_defaultrouter="xxxx:yyyy:zzzz::1"
ipv6_ifconfig_em0="xxxx:yyyy:zzzz::100"
ipv6_ifconfig_em0_alias0="xxxx:yyyy:zzzz::106"
ipv6_ifconfig_em0_alias1="xxxx:yyyy:zzzz::107"
ipv6_static_routes="myroute1"
ipv6_route_myroute1="xxxx:yyyy:zzzz::0/64 xxxx:yyyy:zzzz::1"

If anyone knows why this works, while ::2 did not, I am very curious.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.