I have setup a MaraDNS instance on CentOS 6.5. I can access the DNS records from local machine—on which MaraDNS is installed—by doing nslookup but cannot access the DNS server records from Internet on other machines.

When I do nslookup from other machine via internet, I get:

connection timed out; no servers could be reached

I have setup iptables as:

iptables -I INPUT -p udp --dport 53 -j ACCEPT
  • 1
    As a sanity check, please tell us the nslookup command you are using. Can you connect to your server from the "Internet" (non-local) machine by other means? What happens if you ACCEPT tcp/53? – G-Man Mar 3 '15 at 0:19
  • @G-Man- Below solution worked. Thanks bdw :) – S R Mar 3 '15 at 0:50

Check the bind_address in your /etc/marac file as explained here:

If you want to tie the process to a specific interface, edit the bind_address parameter. This defaults to meaning any interface. If both recursive and authoritative DNS is needed (i.e. you add a zonefile) you have to change this to the specific IP addresse(s) where you need maradns to listen, otherwise it will refuse to start.

So if your bind_address is set to then that would strictly bind it to localhost connections. So if you want the interface to be networked outside of localhost connections, set it to

I don’t use MaraDNS so I’m not 100% sure on the naming of the bind_address parameter, but more info here points to the param being named ipv4_bind_addresses:

ipv4_bind_addresses: The IP addresses to give the MaraDNS server. This accepts one or more ipv4 IPs in dotted-decimal (e.g. "") notation, and specifies what IP addresses the MaraDNS server will listen on. Multiple bind addresses are separated with a comma, like this: ",,"

  • 1
    That helps. I have to add my server's IP address to the bind_address. does not work but after adding my public IP it works! Thanks – S R Mar 3 '15 at 0:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.