3

Hey, I downloaded the Aptanastudio 2.0 and unzipped it in the desktop.

Im trying to run Aptana studio 2.0 under OpenSuse 11 and i get the following error...

Any idea y? Thanks

JVM terminated. Exit code=-1
-Xms40m
-Xmx384m
-Djava.awt.headless=true
-XX:MaxPermSize=256m
-Djava.class.path=/home/avi/Desktop/Aptana Studio 2.0/plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
-os linux
-ws gtk
-arch x86
-showsplash
-launcher /home/avi/Desktop/Aptana Studio 2.0/AptanaStudio
-name AptanaStudio
--launcher.library /home/avi/Desktop/Aptana Studio 2.0/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.200.v20090520/eclipse_1206.so
-startup /home/avi/Desktop/Aptana Studio 2.0/plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar
-application com.aptana.ide.desktop.integration.Application
-vm /usr/lib/jvm/java-1.6.0-openjdk-1.6.0/jre/bin/../lib/i386/client/libjvm.so
-vmargs
-Xms40m
-Xmx384m
-Djava.awt.headless=true
-XX:MaxPermSize=256m
-Djava.class.path=/home/avi/Desktop/Aptana Studio 2.0/plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar 
  • Not really enough information here. Try running Aptana from the command line and see if there are any other information dumped to the terminal. You can use pastebin if you need to to paste it all. – Ryan Gibbons Dec 28 '09 at 13:13
  • Can you please tell me what is the command? \. AptanaStudio wont open it Thanks – fatnjazzy Dec 28 '09 at 13:58
  • Based on the output you posted below, it looks like you are low on memory. How much RAM and swap is in this machine? – prestomation Dec 28 '09 at 14:25
  • duplicate here superuser.com/questions/88518/aptana-under-linux that was migrated from SO (that one should be closed) – therefromhere Dec 28 '09 at 15:32
1

Try installing Eclipse from your package manager, and installing Aptana as an Eclipse plugin, rather than using the standalone version.

|improve this answer|||||
  • I did that but eclipse is not running. Thanks – fatnjazzy Dec 28 '09 at 13:49
  • If you installed Eclipse from the package manager and it's not working, then perhaps you have other issues? – Natalie Adams Apr 27 '13 at 2:48
0

to run it from the command line open the console and write the following:

cd`/home/avi/Desktop/Aptana Studio\ 2\.0/
sudo chmod u+x AptanaStudio
./AptanaStudio

So you can see the output (sudo chmod u+x will change the permission of the application, so the user can launch it).

Hope that helps, Regards

|improve this answer|||||
  • If you have "tab completion" enabled, you could just type cd ~/Desktop/Aptana and press the "tab" button, then the sudo chmod thing, and then again ./Aptana and press tab. – dag729 Dec 28 '09 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.