5

Possible Duplicate:
On Windows 7, is there a command prompt line that can start cmd as an administrator?

Is it possible to force cmd.exe to always run with administrator rights?

2

3 Answers 3

5

If you are in Windows Vista or Windows 7:

  • Press start
  • Type "cmd"
  • Hit Ctrl + Shift + Enter
  • Press Yes to accept the resulting UAC prompt (or Alt + C on Windows Vista, or Alt + Y on Windows 7)

This method will run any application as administrator.

1
  • Pressing <shift>+<ctrl>+<enter> gives a message box "C:\Windows\system32\cmd.exe: Unspecified error"... what could this mean? Windows 7 home premium. Dec 22, 2015 at 21:22
10

In Windows Vista/7 follow these steps to always run the command prompt as an administrator:

  1. Click Start. Type Command. Right-click Command Prompt, and then click Properties.

    enter image description here

  2. On the Shortcut tab, click Advanced.

  3. Select the Run as administrator checkbox.

    enter image description here

  4. Click OK twice.

Now, when you launch a Command Prompt from the Start Menu, UAC will prompt you for administrative privileges.

4
  • You can not do this for command prompt
    – Jonathan.
    Dec 28, 2009 at 15:15
  • but of course you can, screen shots added.
    – Molly7244
    Dec 28, 2009 at 15:32
  • I have checked this box, but running the shortcut brings me to a C:\Users\Username prompt, which I think means it is not running as administrator! Dec 22, 2015 at 21:24
  • @SanjayManohar the Start path is also specified in the Shortcut properties. Most likely you just have C:\Users\--Username-- as the start path. I've confirmed this works for me. I think this is a better solution than the accepted answer.
    – ry4nolson
    Mar 8, 2016 at 15:04
2

If you're using Windows XP, you could create a short cut to cmd.exe in the Quick Launch area and then right click -> Properties and change the Target field. You would preface the command with runas /noprofile /user:DOMAIN\USERNAME

The full text of the command on my computer is

C:\WINDOWS\system32\runas.exe /noprofile /user:DOMAIN\USERNAME %SystemRoot%\system32\cmd.exe
2
  • You can also edit the "Advanced" settings on shortcut properties and check "Run as administrator".
    – RJFalconer
    Dec 28, 2009 at 14:06
  • I don't see this in XP but you can do that in 7.
    – rodey
    Dec 28, 2009 at 14:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.