24

Checkpoint’s Endpoint Security VPN Client starts when I log into my Mac (Mac OS X 10.9.5).

  • How can I make it not start automatically?
  • Then, how can I start it manually when I need it?
  • Good use of a simple and useful self-answering question. – JakeGould Mar 4 '15 at 5:18
  • I still can't find a solution for this issue. I'm running macOS Catalina. – dcolumbus Dec 15 '19 at 18:56
  • I still can't find a solution for this issue. I'm running macOS High Sierra – sandoval31 May 2 at 16:59
36

To stop it from starting automatically, edit /Library/LaunchAgents/com.checkpoint.eps.gui.plist and change:

<key>RunAtLoad</key>
<true/>

To:

<key>RunAtLoad</key>
<false/>

Then to start it when you need it, look in the Applications folder, it’s called, “Endpoint Security VPN.”

| improve this answer | |
  • 1
    I wonder if we have similar file in WIndows. It seems not having the same file structure as Mac OS o ne though. – Shinigamae Oct 12 '15 at 2:30
  • 2
    Very annoying that there is no option within the user interface to toggle auto start... – Alex Mar 14 '16 at 6:40
  • 6
    Thanks for this.. the checkpoint VPN client is one the worst thing I've ever seen – Mariano L Mar 17 '16 at 19:46
  • 1
    This technique also works for TigerVPN's OSX client. – kabadisha May 31 '16 at 13:57
  • 1
    It still works on macOS Sierra – Dirk Dec 20 '16 at 20:51
1

Simplest way to stop the Check Point End Client auto launch on Mac OS.

Right click the End client padlock in the 'Menu Bar'. From the Drop-down select VPN Options> When the Options popup window opens, Select> the Properties Button> next, Select> Settings tab> Under the Always-Connect section> Un-check the box> Enable Always-Connect! Click (OK) to save the configuration. Presto...no more annoying auto launch logon window.

Next time you need to connect to your VPN: Right click the padlock in the Menu Bar and select Connect from the Drop-down.

| improve this answer | |
  • "Enable Always-Connect" is greyed out for me. – dcolumbus Apr 10 '19 at 20:40
-1

In MacOS High Sierra the steps are nearly the same but one more file needs to be changed. Just do the following:

To stop it from starting automatically, edit /Library/LaunchAgents/com.checkpoint.eps.gui.plist and change:

<key>RunAtLoad</key>
<true/>

To:

<key>RunAtLoad</key>
<false/>

Then do the same in one more file, edit /Library/LaunchDaemons/com.checkpoint.epc.service.plist and change:

<key>RunAtLoad</key>
<true/>

To:

<key>RunAtLoad</key>
<false/>

Then to start it when you need it, look in the Applications folder, it’s called, “Endpoint Security VPN.”

| improve this answer | |
  • 1
    Changing both settings had no effect for me; still autostarts. On macOS Mojave 10.14.6. – Richard Kiefer Nov 25 '19 at 8:38
  • Doesn't work for me. – dcolumbus Dec 15 '19 at 18:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.