0

Gentoo is on /dev/sda4 and /dev/sda3 is /boot,/boot/kernel-genkernel-x86-3.18.7-gentoo and /boot/initramfs-genkernel-x86-3.18.7-gentoo both are genkernel-built,but GRUB says:could not find the root device in /dev/sda4. Here is my fstab:https://pastebin.anthonos.org/view/6958e8c8 (Already tried to replace /dev with UUID,not work) And this grub.cfg:https://pastebin.anthonos.org/view/639f93dd grub can load Windows,so I'm sure that grub's binary isn't broken. What to do?

  • is the UUID of your Gentoo partition ab8313f8-2c6d-4f60-88a0-f3d8e1472437 ? If not then that explains your problem... – gogoud Mar 4 '15 at 17:38
  • @gogoud What's the problem?I didn't see this UUID when grub report error,this should be /boot's UUID – Yu Zhang Mar 4 '15 at 17:40
  • 1
    can you give the exact message you see when grub gives up? does it drop to a grub shell prompt? – gogoud Mar 4 '15 at 17:46
  • @gogoud I can't get screenshot because I don't have a cam,It just showed could not find the root device in (Depends on fstab set),and says Press Enter for the same ,'shell' to into shell,and 'q' to skip.No kernel panic. – Yu Zhang Mar 4 '15 at 17:50
0

Solved.Because Genkernel(not Genkernel-next)doesn't contain ext4fs support.Since I complied kernel myself,solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.