I'm trying to use Task Scheduler to run a Ruby script every night. When I try to run the script, I get error 0x8007010B which seems to be Directory Name Invalid. The directory I'm starting in is a mapped network drive. Performing the equivalent action from the command line works fine. Here's the action I'm trying to perform along with a piece of the command line window showing that both directory names are valid.

Action configuration

Why is Task Scheduler claiming the directory name is invalid?

2 Answers 2


I had the same problem but more generic: The Start in (optional) field doesn't support quotes (e.g. "C:\Program Files"). I removed them and it worked!

  • There's an explanation with diagrams here Nov 18, 2020 at 9:00

I worked around the issue by adding another Action in Task Scheduler to run net use M: <path to network folder>.

This task worked correctly when the computer was connected to a domain, but we took down our buggy domain server. For whatever reason, Task Scheduler used to know that M: was mapped to a network drive but now it doesn't.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.