20

Conemu uses CTRL+V as the short cut to “paste first line of clipboad.” I want this functionality when I’m interacting with the command-line, but when I’m in Vim I’d like Vim to handle it.

3
  • Per-application hotkeys are not supported. Yet at least.
    – Maximus
    Mar 4, 2015 at 21:37
  • @Maximus any update on this? I don't care about using Ctrl-V outside of Vim.
    – blah238
    Oct 17, 2015 at 1:00
  • Never mind, I added an answer that works for me.
    – blah238
    Oct 17, 2015 at 1:04

4 Answers 4

18

You can use Ctrl + Shift + V instead.

2
  • 1
    I suppose that this is not so terrible. Mar 23, 2018 at 23:18
  • 2
    A little terrible. Nice to know, though.
    – Sigfried
    May 8, 2019 at 14:27
17

For future Googlers, unbinding Ctrl + V in Settings->Keys & Macro allows Vim to handle it. You can use right-click to paste instead.

1
  • 2
    right-click is not ctrl+v
    – Manachi
    Sep 13, 2017 at 0:39
1

This is basically just a synthesis of the two other answers, but the workaround I ended up using was to go into Settings->Keys & Macro and change the binding for CTRL+V to CTRL+SHIFT+V.

1

You are using vim inside of ConEmu why don't use vim key to paste from system's clipboard to vim.

Use "*p key combinations to paste in vim.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .