0

I have a switch D-Link DGS-1210 with 52 ports. There is a device connected to the switch that shall be updated. The update requires a TFTP transfer between my PC and the device.

Unfortunately the switch drops the UDP packet to port 69 that should initiate the transfer. All other UDP packets go through. I have monitored the traffic with Wireshark to verify this.

There are no VLANs configured.

Is there any option to detect, why UDP packets to the port 69 are not forwarded?

The TFTP transfer is not intended to update the D-Link DGS-1210 but a device connected to it.

Edit: I have connected a dumb hub (each packet is repeat at all ports, NO intelligence) at the switch. The hub connects

  • the device
  • the switch
  • a PC with Wireshark, let's call it Wireshark B

At the PC I run the TFTP client and Wireshark, let's call ist Wireshark A. The device implements the TFTP server, even if there is often the other way round.

I can see the UDP packet to port 69 at "Wireshark A" to the correct IP address. I cannot see the same packet at "Wireshark B". All other packets to the same IP address are passed through.

Edit: The problem has been reproduced with a different PC at the same switch.

The TFTP communication from any PC is without a problem when I replace the D-Link DGS-1210 with a different switch. Unfortunately this requires additional cables and can be only used as a temporary workaround. But we can exclude the doubt about PC based firewalls.

  • How are you sure the switch drops those packets? – Dan Mar 5 '15 at 13:46
  • On TFTP the device sends a request to the server (your PC) using UDP port 69. Have you checked that is sending it to the correct IP and MAC address? – jcbermu Mar 5 '15 at 14:03
  • Yes, "I have monitored the traffic with Wireshark to verify this." – harper Mar 5 '15 at 14:04
  • Did you proof if you can define a mirror port on the switch to sniffer the drop on the switch? – ryder Mar 5 '15 at 14:09
  • @ryder Yes, please see my edit. – harper Mar 5 '15 at 15:19
0

Same problem. The switch really drops UDP packets to port 69. The problem could be related to the "blat attack DoS" system, even when disabled.

Upgrading the switch to fw version 4.10, released on jan 2016, solved the problem. Take a look to the release notes from dlink.

|improve this answer|||||
0

I have updated the switch firmware. The new version passes all UDP/69 packets through except the packets the packets with matching IP destination address. So it was just a bug in the firmware.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.