1

Ctrl+; is not working to insert the current date and time into Excel 2013.

How can I fix that?

UPDATE

Glitch disappeared when Excel restart, so nobody knows the reason and I awarded just "direct" answer.

UPDATE 2

Suppose Ctrl+; is not working and Excel restart doesn't help.

What can prevent shortcut from working?

2
  • What happens when you try it? – DavidPostill Mar 5 '15 at 17:19
  • Nothing happens – Dims Mar 5 '15 at 17:20
3

How do I insert the current data and time in Excel?

To insert the current date and time, Ctrl+; (semicolon), then Space, then Ctrl+Shift+: (colon).


Ctrl+; (semicolon) Insert current date

Ctrl+Shift+: (colon) Insert current time

Source Excel 2013 Shortcuts

3
  • I know this, but suppose it is not working. – Dims Mar 5 '15 at 17:22
  • 2
    Do other control keys work? – DavidPostill Mar 5 '15 at 17:26
  • Yes, most other control keys work – Dims Aug 18 '16 at 18:35
2

What can prevent shortcut from working?

If you switch your keyboard to a language that has the semicolon on a different key that requires Shift to type it and then start Excel, the shortcut Ctrl+; doesn't work. The shortcut Ctrl+Shift+: may still work for inserting time.

Switching the keyboard back to English may solve the problem in some cases, but not always. Closing and reopening the document may also not help. The only reliable way I found to solve the problem is restarting Excel after switching the keyboard to English (or a language that doesn't require Shift to type the semicolon).

0

Wondering why the suggested answers do not work for you.

Try this Excel Addin that inserts dates on worksheets

http://excelfort.com/2015/01/10/pop-up_calendar_excel/

0

If Ctrl+; is not working, then Ctrl+Shift+H almost certainly will work.

0

The problem with my set-up was only mentioned in one website, called "nutsandboltsspeedtraining.com". I had reinstalled TinySpell the other day, a very useful spellchecker that runs in the background, but unknown to me the latest version uses Ctrl+; as a keyboard shortcut within the app, which disabled it in Excel. Cancelling the shortcut in TinySpell settings restored normal service.

There are probably plenty of other little utilities running in the background that could do this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.