11

iTunes is always popping up on my HTPC Mac Mini and I don't use it. It is running Snow Leopard if that makes any difference to the solution

  • 5
    Slow Leopard? Sounds like you have an opinion about Apple's new OS. – ephilip Dec 28 '09 at 20:29
  • 2
    lol, that's a funny typo – Paul Lockwood Dec 28 '09 at 23:47
5

Of course, check out the Apple support article, Removing iTunes for Mac OS X . (note: no longer links to the expected article, appears to have been removed.)

UPDATE: Here's an article for removing iTunes in Lion.

| improve this answer | |
  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Canadian Luke Oct 17 '12 at 23:32
31

If you want to just disable it, run sudo chmod -x /Applications/iTunes.app
It won't work anymore.

If you want it back, just sudo chmod +x /Applications/iTunes.app

On more recent versions of macOS, you may need to disable SIP:

  1. Power off your device
  2. Power on your device while maintaining and R pressed
  3. Once you reach the recovery system, select Terminal from the Utilities menu
  4. Type csrutil disable and then reboot

If you want to revert that back to the original protection, run the same steps but replace with csrutil enable at step 4.

Check the current status with csrutil status in any terminal window.

| improve this answer | |
  • 3
    This is a neat, non-destructive solution. – spume Nov 17 '14 at 13:47
  • thanks for this - iTunes is far too invasive, this is just what I needed – lfender6445 Mar 17 '15 at 19:35
  • Good solution, only downside is that App Store keeps trying to update iTunes even though it's already updated :( – damd Jun 9 '17 at 12:04
  • @damd: I haven't had this issue, what is your OS? I'm on the latest Sierra and iTunes gets updated only when the app store has an update for it. – Benoit Duffez Jun 9 '17 at 15:49
  • I think you should be able to uninstall, disable, and define privileges on ALL software like you can on apps and all apps should run without those privileges. The main one is to disable network access per app. I write software for a living and it's a security breach to not have control of the system privileges apps have. In fact, other apps should be able to take part in SIP. – 1.21 gigawatts Apr 10 '19 at 21:07
0

If this is happening when you insert a Music CD or DVD then it's easy...

System Preferences > CDs & DVDs

In the drop down list labelled "When you insert a Music CD:" (or "...DVD:") select "ignore".

| improve this answer | |
0

How I disabled iTunes. Highlight the non running iTunes app and click command i and under sharing and permission give yourself access to read and write. You may need to give yourself root access first. Compress iTunes incase you want to retrieve it. Move iTunes to the trash and click delete.You may need to open Activity monitor and quit the iTunes Helper App first.

| improve this answer | |
-1

iTunes, doesn't "just pop" up. It has to be started.

1) Check in the Dock, right click on the iTunes icon, is "Open at Login" checked? 2) Do you have an iPod, iPod Touch, or iPhone? If so, when the device is connected, go into iTunes. Click on it in the sources list, and uncheck the "automatically sync when connected".

Those are the options that I can think of off the top of my head... But iTunes should not be starting without a reason.

Oh, it'll also start up if you have it set to automatically download track information for CDs / DVDs from the internet.... When you insert the discs...

But I think that's it.

| improve this answer | |
  • Could have been DVDs left in the drive. Also it started up when charging an iPod. I sync the iPod with a different machine but we tend to charge things off the htpc because it is always on – Paul Lockwood Dec 28 '09 at 23:51
  • If you are charging an iPod/iPhone/etc, just turn off the "Automatically sync when connected" in iTunes for that particular iPod... That would prevent it from starting up when you plug in the iPhone/iPod. – Benjamin Schollnick Dec 29 '09 at 3:17
  • uninstalling worked even better :) – Paul Lockwood Dec 30 '09 at 1:46
  • I know this is old... But there's also the iTunes helper app. Go to System Preferences => Users and Groups, look in Login Items, see if you have iTunes Helper there. Remove it if it is. – Rich Homolka Jul 1 '14 at 14:19
  • 1
    I've known iTunes to fire up when the play/pause button on a keyboard is used, and when an Apple IR remote is used. – spume Nov 17 '14 at 13:42
-1

The terminal command doesn't work for me in OSX 10.8.5 anymore so I found a workaround.

  1. Quit iTunes helper using Activity Monitor.
  2. Give yourself permission to read and write using iTunes get info
  3. Use dropDMG and make a disc image of iTunes in case you need iTunes for some reason
  4. Find iTunes, right click "show package content", click Macos, send iTunes and helper 1&2 to the trash and delete
  5. Never software update iTunes

Hope this helps

| improve this answer | |
  • Can you specify which terminal command you are referring to? – lzam Sep 22 '14 at 2:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.