2

Been searching all over the place and not finding it. I have a Macbook Pro (Retina, 15-inch, mid-2014) and I am trying to boot it into single user mode (root console). All the instructions I find say to boot it (power on or restart) and immediately hold the Command+S keys. I've tried it over a dozen times with various timings on hitting Cmd-S and the computer simply boots to its normal login screen.

I do not have the firmware password enabled; however, I do have FileVault active on my user account. Would that matter? I've searched whether FileVault disables single user mode and all I get are instructions for booting to single user mode -- which doesn't work for me.

I'm following the instructions on this Apple page: https://support.apple.com/en-us/HT201573

Note that booting in Verbose mode (Cmd-V) also doesn't work for me.

Edit: Should have mentioned I'm running Yosemite, v10.10.2

  • What OS are you on. According to derflounder.wordpress.com/2013/04/26/… it should work – Kevin Grabher Mar 6 '15 at 21:58
  • Also - when you press alt after starting, does it work for you to get the boot options? – Kevin Grabher Mar 6 '15 at 21:59
  • OS is Yosemite v10.10.2. I read the article, and it describes what I am doing: Pressing Cmd-S after booting. It takes me to the normal login screen and I log in, which takes me to my normal desktop. If I press the alt key after restarting, I do get taken to the boot options. I have to log in to FileVault and then I see Macintosh HD as a boot option. I click that and it boots normally. – user3112401 Mar 7 '15 at 1:26
  • I get the same behavior as @user3112401. – fakewaffle May 7 '15 at 17:20
2

BACK IN MY DAY:

I seem to remember once having precise-enough timing such that I booted true single-user mode successfully. This of course is not an option if you can’t boot the mac at all, but if you have and can boot to the Recovery Partition, the basic GUI is loaded but the System Drive is mounted read-only. This means running Disk Utility to repair the partition will not take up the remainder of time before your hardware is End-of-Lifed and command line fsck will work (although you may have to type the full path to it):

# /sbin/fsck -fy

and optionally:

# /sbin/mount -uw /

if you want to remount the System Drive as writable before you boot back into your whole-nine-yards OS X (e.g. to delete an gargantuan file someone may have created when you taught them about the magic of dd but didn’t consider the implications of

dd if=/dev/urandom of=/Users/stooey/teensy-file bs=512 without impressing the importance of the count=512000000 argument. (Pshaw! Of course you mentioned it! I always think of everything!)

THE REASONING:

I have been an Unix Admin for so long seeing a blank grey screen with the Apple logo may reinforce our voluntary brainwashing/zealotry, I prefer to see what’s happening in “real-time.” This can be of utmost importance when your machine is an OS X Server or just OS X who happens to be running server(s) ( must be connected to the network, but you want to at least know who’s doing what before you gave them your blessing or you’re acting outside the maintenance window and you hope nobody notices or tries to access any given facility you don’t want them to. They will, and they absolutely will.

THE SOLUTION (friggin’ finally!):

I changed the nvram so that whatever undermining force what activates my A.D.D. upon reboot (or I don’t want to appear to be a rube when educating and miss a crucial timeout expiry or App Store has been updating, and I’m busy SMSing, I have my system always boot verbose:

sudo nvram boot-args="-v"

but doing this to boot single-user (also implies verbose) is also possible:

sudo nvram boot-args="-s"

Once you've booted into it, you will want to change it to normal verbose boot or remove the argument in nvram (formerly PRAM for old souls [pre-Intel]) or it will always boot single-user mode which would make me a little despondent after very few reboots.

sudo nvram -d boot-args

HOPE THIS HELPS! ^.^

|improve this answer|||||
1

try pressing the key after the startup chime, in the boot menu select your bootvolume, and right after (!!) pressing return press the for single user mode. you should see the SU-mode for half a second after that before filevault asks for password after which the mac should boot in SU-Mode. worked for me at least.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.