1

Symptom:
Delays of up to 30 seconds resolving DNS when plugged in to or Wif Connected to second router.
Ping can take just as long via domain name, near instant via IP No problems when connecting directly to the router with direct internet connection
Problem presents regardless of OS or of the connection method (wired vs wifi)

Infrastructure Physical Setup:
Plusnet provided Technicolor TG582n (4 x 100 Mbit, Wifi) - Connected to ISP over ADSL
D-Link DSR-250n (8 x 1000 Mbit, Wifi) - Connected to above router using WAN port PC - Connected to D-Link, wired Laptop - Connected to D-Link, Wi-Fi Numerous android devices

Software / Firmware Settings:

  • ADSL router - Wifi off. DMZ set to 2nd router. IP 192.168.1.254
  • D-Link router - WAN interface IP 192.168.1.66. Internet set up as "Dynamic IP (DHCP)" and DNS as "Get dynamically from ISP"
    LAN IP 192.168.0.200. DHCP server on. DNS servers 212.159.13.49 (primary) 8.8.4.4 (secondary). DNS Proxy off.

Attempted fixes:
Setting DNS server IPs manually on client PC, tablet etc... No improvement
Disabling DNS Proxy on Router no effect
Disabling DHCP on second router manually setting IP/DNS/Gateway

  • 1
    First of all you should never connect the second router via the WAN port if it's behind another router. This is double NATing and isn't a good idea. Give the second router a static IP within your first router LAN subnet -> set the second router gateway IP to that of your first router -> turn off DHCP on the second router -> move the WAN cable on second router to one of its LAN sockets. DNS and network should then work fine. – Kinnectus Mar 7 '15 at 13:04
  • Doesn't placing the second router in the DMZ of the first negate the double NATting you mention? – G-. Mar 7 '15 at 13:06
  • Only if you want that device open to the Internet... Not really best practice when you should only put, say, a firewall device in the DMZ and if you need all ports open to this device. NAT is a device translating external to internal addresses so the internal is never exposed. This doesn't work the way you think. – Kinnectus Mar 7 '15 at 13:10
  • 2
    Ok, you'll need to turn off all DHCP on the first router -> the tecnicolor devices allow giving a device on the LAN the "public" ISP IP. This in effect exposes the device to the Internet. You'll need to turn off DHCP on the first router and it should have a static IP – Kinnectus Mar 7 '15 at 13:15
  • 1
    DHCP off first router. IP assigned to second. Second router set to consider it's "ISP" as static IP address. Problem appears solved! If you'd like to write up your answer below, I'll happily accept it. Thanks! – G-. Mar 7 '15 at 13:58
2

The Tecnicolor modem/routers allow you to give one device (by its MAC address) on your internal LAN the "public" IP. This, essentially, puts that device in the DMZ but, at the same time, the device is contactable through your public IP - basically turning the Tecnicolor into just a modem.

As your DMZ device is also a router providing NAT and DHCP I would recommend you disable the DHCP server capabilities of your Tecnicolor router as this will cause problems. I would also recommend turning off the LAN and WiFi capabilities of the Tecnicolor as accidentally connecting to these will only give you Internet and no ability to connect to the other LAN.

Apart from managing the Tecnicolor modem through its GUI you'll never need to use its addresses as your other router is doing all the work.

0

I can't comment yet so will put this as an answer. Try first pinging a host name with a . on the end. Eg if ping www.google.com takes 30s to resolve then try ping www.google.com. and see if you get a response right away. If you do you have a DNS suffix issue. You should be able to adjust this in the DHCP settings.

  • Thank you for your response. I've resolved the issue with Chris's help in the comments above – G-. Mar 7 '15 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.