I am trying to use alternate terminal emulator for CygWin in Windows 8.1 x64. I am trying to use [ConEmu] and [Console], but both of them fails in rendering of mc program.

Midnight Commander

Is it fixable?

  • Unfortunally I can not attach more than 1 link to post, so ConEmu screen is here: i.imgur.com/RpgaEzs.png – Artur Eshenbrener Mar 8 '15 at 11:29
  • I just found out that setting TERM=linux might help, provided that you already have LANG=ru_RU.UTF-8, — that way both national characters and graphic symbols are drawn, unlike when TERM=cygwin. – Anton Samsonov Apr 4 '16 at 11:46

Your reference to your LANG setting solved it for me. I got:

$ locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_ALL=

Starting mc with LANG=C mc fixed it for me. You might want to set this into your .bashrc or .profile.

  • It doesn't work( – user1248256 Sep 16 '15 at 15:52
  • It's been some time. Conemu might have changed since then. – Ben Sep 16 '15 at 19:23

Seems like your mc/cygwin installation is broken. The origin of the problem is the fact "mc is trying to write utf-8 to console". But it hasn't properly prepared it.

The problem don't relate to ConEmu or Console2. If you run mc from Win+R you will get the same result. Check your cygwin/mc configs, refer to their manuals or contact with their developers.

BTW, I have no problems with mc in my trst box. So I can't say what is wrong in your settings. It will be interesting to get information about it if you solve the problem.

  • 2
    Inside standard Cygwon terminal emulator, mintty, everything works good. Locale settings are completely equals, ru_RU.UTF-8. Could you help me with debug it? – Artur Eshenbrener Mar 8 '15 at 18:10
  • mintty works completely different than expected in Windows. wiki. So you can't compare mintty with ConEmu. The only valid comparison will be, as I've said before, with mc started from Win+R. – Maximus Mar 8 '15 at 23:53

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.