6

I've been having problems with the Windows clock for a while. I tried a variety of solutions, but nothing seemed to really work, so finally I just decided to disable the automated internet time synchronization, set manually the correct time, and the problems seemed to be gone (meaning that the displayed time keeps being what it should). I'm in the Amsterdam, Berlin, Rome, Stockholm, Vienna time zone, and that is correctly set in the Date and Time menu.

However, I started noticing a series of odd behaviors, which makes me wonder what is going on under the hood. To better understand the issue, I will use as an example in the following the actual time (up to some minutes) at which I'm writing this: 22:43:15.

  • The clock shown in the bottom-right of the screen, which I manually set up, shows the correct time.
  • Going to a site like time.is confirms me that the displayed time is indeed correct, however the site tells me that my clock is 9 hours, 2 minutes and 10.9 seconds behind. All the other information, like place and date, are correctly displayed from the site.
  • If I let windows do the internet synchronization (and I tried this with various time servers), the few times that I'm allowed to do that without the "you do not have permission to do this" error, the displayed time changes to 7:43 of the day after, but time.is, while clearly in contrast with the time displayed on the pc's clock, tells me that my clock is in sync.

So it seems that there is some "hidden clock" which is not displayed but which is read by internet services, and that somehow this clock disagrees with the one displayed on screen.

Other online services like Gmail seem to be reading from this "hidden clock", showing wrong arrival hours for email and similar things.

What is going on? And how can I fix this?


Further tests:

I tried to change the time zone to another one and to go back to the correct one (after appropriate reboots). The results would be funny if not really annoying.

Right now is 9:00.
With UTC+1 Amsterdam/Berlin/ecc. I get the incorrect 18:00, 9 hours off.
With UTC Dublin/Lisbon/London I get the "correct" 8:02 which is an hour off as it should.

But it gets better: looking more carefully at the drop-down menu with the various time zones, I noticed a strange thing, which possibly explains the source of the issue: the UTC+1 Amsterdam/etc. timezone is listed among the UTC+10 time zones. Here is a screenshot of the drop-down menu: enter image description here

A couple of further tests confirms this: Windows somehow considers the UTC+1 Amsterdam time zone as a UTC+10 time zone. In fact, changing the time zone to another UTC+1 like UTC+1 Brussel/ecc. gives me the correct hour.

This is a useful workaround, but how in the world can this be changed back to normal behavior (possibly without having to use system restore and such)?

  • What timezone is your computer set to use? Is it the correct timezone for your location in the world? – Kenster Mar 8 '15 at 21:36
  • What timezone have you entered for the time and date settings? They have to be correct too. – LPChip Mar 8 '15 at 21:36
  • @Kenster the time zone is correct, too. At least the one displayed in the Date and Time menu. – glS Mar 8 '15 at 21:39
  • when I go to time.is, it also tells me my location. What location is it telling on your end? Do you maybe use a VPN or anything that interfears with how time.is gets your location? – LPChip Mar 8 '15 at 21:48
  • @LPChip As I've said in the post, the location is correctly displayed on time.is. I'm not using any VPN, proxy or such. – glS Mar 8 '15 at 21:50
6

You probably haven't told your Windows PC what part of the world you're in. Without that information it can't offset the "Internet time" to the correct value.

  • Right-click the clock in the bottom right-hand corner
  • Choose the menu option "Adjust date/time"
  • Click the button [Change time zone...]
  • Choose the correct capital city of other significant town for the region that you are in
  • If your region uses Daylight Saving Time (i.e. the time changes by an hour twice a year), tick that box too

Since your PC is being told its clock is 9 hours behind, likely candidates for your local region are Tokyo, Seoul or Yakutsk. Alternatively, if I've misunderstood your explanation of which way the clock is wrong, you might be in Alaska.


Based our investigations it seems that your Amsterdam entry in the timezone database may be corrupted. This article from the Microsoft Technet gives a little explanation of the Timezone database in the registry. Looking at HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones I can find an entry for W. Europe Standard Time that corresponds to the Amsterdam timezone. Here are entries from a Windows 7 PC that appear to work correctly:

Display     REG_SZ     (UTC+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna
Dlt         REG_SZ     W. Europe Daylight Time
MUI_Display REG_SZ     @tzred.dll,-320
MUI_Dlt     REG_SZ     @tzres.dll,-321
MUI_Std     REG_SZ     @tzres.dll,-322
Std         REG_SZ     W. Europe Standard Time
TZI         REG_BINARY C4 FF FF FF 00 00 00 00 C4 FF FF FF 00 00 0A 00 00 00 05 00 03 00 00 00 00 00 00 00 00 00 03 00 00 00 05 00 02 00 00 00 00 00 00 00
  • the time zone is displayed correctly in that menu. There is not checkbox for Daylight Saving time, though. – glS Mar 8 '15 at 21:40
  • @Glance, where in the world are you, please? – roaima Mar 8 '15 at 21:42
  • UTC+1 time zone. See the edit to the post – glS Mar 8 '15 at 21:45
  • @Glance please humour me a little and set your timezone to "somewhere else", e.g. Dublin/Lisbon/London. Reboot the PC. Using an Internet time source such as eu.pool.ntp.org check whether you're now the expected hour behind your true time. Set the timezone back to your correct location. I'm thinking that something has got confused in the registry and I'm curious to know whether changing the timezone resets what I can only see as a zone error. – roaima Mar 8 '15 at 23:22
  • 1
    Awesome. Looking at the registry key you quoted I noticed that the TZI value was different. Changing it to the value you gave solved the problem. Thanks! – glS Mar 9 '15 at 9:58
0

For me it worked to change the server from time.windows.com to timetime.nist.gov.

For some reason it was showing the wrong time with everything set to automatic. My mobile devices were showing the correct times that's when i got suspicious.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.