0

I recently switched to a Belkin N150 wireless router, and I can no longer connect to other machines on my wireless network. Whenever I try to ping or ssh to another laptop on the network, it just hangs. Additionally, if I start a web server my laptop, I can't access it from any other machine (phones included). Similarly to ssh, they just hang while trying to load it.

Before this router I had an older Airport Extreme, and I did not have any issues connecting to other machines.

Why can't I connect to other machines?

Things I've tried:

  • Connecting either via IP or .local
  • Switching ports for the HTTP server (and using 0.0.0.0 as the hostname)
  • Checking the router logs to ensure that I'm hitting the correct IP's
  • ssh'ing or loading the webpage on the computer serving it up (to ensure that I've got the correct port/IP address)
  • arp(8)'ing the other host with arp <other ip> — I get (incomplete) for the link layer address
  • arp -l -a(incomplete) for the other machines' link layer addresses
  • sudo arp -d -a — still doesn't fix it
0

I updated the firmware and this is all working now. ~*facepalm*~

It's an N150 V1, so I downloaded the 1.00.13 version firmware from Belkin's skeezy, not-https firmware updates page, so I'm probably getting hacked rn. Oh wait, the page title says "official," I'm sure it's cool.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.