2

So, this is the thing, I have 2 Floors, Internet modem (Huawei hg532e) is upstairs, I needed Internet coverage on both floors, so I decided to install a Powerline network because the Wi-Fi wasn’t enough since I have thick walls and floors. So, the Powerline go downstairs, and it is connected to a router.

I normally access the NAS using SMB (Samba), NFS and/or uPnP. When I go to Network on a Windows computer, I see the NAS as a computer in the network and also as a media device (I have both protocols enabled on the NAS)

The problem here is that the computers connected to the downstairs router are not able to get access to the NAS.

I was considering disabling the DHCP server on the downstairs router… But, that would require specific configuration on each device, and would not address the issue. I was also considering putting the downstairs router (TRENDnet TEW-731BR; Version v2.0R) on access point mode, but I don't see such option.

I tried to set the upstairs modem on: 192.168.1.254, with address pool of: 192.168.1.65 to 192.168.1.253, and mask: 255.255.255.0 and the downstairs router on: 192.168.1.64, with address pool of: 192.168.1.1 to 192.168.1.63. But it did not worked and I lost access to the downstairs router and had to reset it and reconfigure. I was wondering if there's any other kind of solution.

I’m still learning networking, and I know all the basics but I have no idea here. Here is a pic of the network layout for reference.

enter image description here

  • How are you trying to access the NAS? – user2313067 Mar 9 '15 at 6:23
  • I normally access the NAS using SMB (Samba), NFS and/or uPnP. When I go to Network, on a Windows computer, I see the NAS as a computer in the network and also as a media device (I have both protocols enabled on the NAS). Thanks for the remark I already added this info to the original question. – David Muñoz Mar 9 '15 at 7:29
  • For such a small network you SHOULD disable DHCP on the downstairs router and let your ISP's device do all the hard work. Set your downstairs router into "access-point" or "bridge" mode (or manually configure it with a static (or reserved) IP (outside of the DHCP scope of the router, though), same subnet as upstairs and gateway IP of your ISP router and disable DHCP server). This will then bring your downstairs network into the same network, subnet and gateway as the rest of your network so you can access the NAS and the Internet. You've made your network unnecessarily complicated. – Kinnectus Mar 9 '15 at 9:30
  • If you don't have an "access point" or "bridge" mode then you need to manually disable DHCP capabilities and set static details such as IP, subnet and gateway. E.g. ISP/DHCP Scope: 192.168.1.100-199 with subnet of 255.255.255.0 and gateway is 192.168.1.254 then give downstairs static IP of .99 or .200, subnet 255.255.255.0 and gateway 192.168.1.254. Alternatively, you may be able to "reserve" the downstairs router an IP using your ISP's web interface and the downstairs MAC address... this will allow the device to obtain its own address but you MUST turn off its ability to act as a DHCP server. – Kinnectus Mar 9 '15 at 9:35
0

The best way would be to bridge the two (upstairs and downstairs) networks together, so that they are on the same flat network (same router, same IP address range). It is weird that you say that your downstairs router does not support this mode...

If bridging is not an option, you should put your two subnets (upstairs and downstairs) into different IP address ranges, i.e. 192.168.1.x and 192.168.2.x. Samba should work across routed networks (http://www.tldp.org/HOWTO/SMB-HOWTO-12.html), but you first need to check that basic IP connectivity works.

0

Thanks Big Chris and Demiurg for your answers, unfortunately, that trendnet router happened to be pretty basic and lacks such option as AP mode or Bridge mode. I also tried your suggestion of using 2 different subnets, apparently, the combination of modem/router that I have doesn't allow such thing, it causes conflicts and I ended up losing connectivity to the router configuration interface and also I lost internet connectivity. I double and triple-checked my subnet settings, I tried several times, rebooted all devices etc. I had to make a factory reset and reconfiguration in order to get it working again. What I ended up doing is adding a wired switch downstairs, and then connecting the computer directly to the switch and the router to the switch, the computers connected wirelessly to the router have no access to the NAS, but that was not a must, the desktop PC is working like a charm with the NAS. So, my diagram ended up like this. http://i.imgur.com/qxJMqDx.pngDiagram

Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.