I have big problem with Plextor SSD M6S 128 MB (firmware 1.07).

Last Friday I've shut down my computer and turned off the power strip. Yesterday evening, I tried to turn on the computer.

When there is "Press F2 or DELETE to enter setup" on the screen (at POST phase), everything freeze.

  • I can enter the BIOS (but it takes about 2-3 min after I press "del")
  • BIOS doesn't see SSD
  • if I'm not entering BIOS, computer freezes at abovementioned phase and finally after 3-5 minutes stops responding or shows typical message: "Reboot and select proper Boot device"
  • when SSD is unplugged, everything is OK (no freezes, etc.) (unfortunately I don't have another HDD with OS to do sth more).

I've tried following:

  • change ports and cables
  • unplug all other HDD
  • change SATA mode to IDE or AHCI
  • reset BIOS to default settings
  • enable / disable ErP in BIOs
  • enable / disable Power Loading in BIOS
  • When I set SATA mode to RAID, M6S is detected in BIOS an Intel Rapid Storage Technology boot manager (I don't know how it is really called) (IRST in BIOS disabled). But in IRST Configuration Tool it disappears again.
  • When I set SATA mode to AHCI and set IRST to enabled in BIOS, SSD is detected in BIOS, but this is the only change - freezes during POST still present and no boot device. [update] - this sometimes work, sometime not

My full config: Gigabyte Z97X-Gaming 5 | Intel Core i5 4690k | G.SKILL 8GB 2133MHz RipjawsX CL9 | GeForce GTX650Ti Boost OC 2GB 192b | Plextor M6S 128GB | Samsung F3 500GB 16MB cache SATA-II HD502HJ & Samsung F1 640GB 7200rpm 16MB cache SATA-II HD642JJ | Sound Blaster Audigy SE 7.1 EAX

I have no idea what to do. Maybe it is dead. I'm going to check it tomorrow with my friend's machine, but maybe you van help me earlier.

[update] Test with my friend on old Asus P5K Pro: first time SSD was detected, Windows - intalled on different HDD - failed to start. Next time BIOS hangs when detecting AHCI devices on port with my Plextor and since then it happens all the time.

Thanks for any help.

  • 1
    Yup, sounds like you did try everything and it's faulty, do check on another machine. If familiar with linux, you could boot a live cd of your choice, and if it detects the ssd, examine smart data with smartmontools, if not check dmesg for any errors. – Dan Mar 9 '15 at 10:21
  • Checked on another machine, details above. – long Mar 9 '15 at 18:13

Ok, problem solved (I hope so).

In BIOS, I changed Boot Mode Selection from default UEFI and Legacy to Legacy only. Result: SSD is detected, Windows started, everything works perfect, no freezes.

But when I set BMS back to UEFI and Legacy... SSD is still detected, everything OK. I don't get it, I have to read more about it.

  • Too summarise: You want to your desktops firmware (which contains an UEFI program and not a BIOS program). Changed a few settings forth and back and now it works again. Possibly due to a corrupted setting. (which means a general firmware reset also might have solved this). – Hennes Oct 15 '15 at 12:53
  • 1
    If this happens again then check the battery on your motherboard. (It has a small battery to keep the time and the firmware settings. If the PC is fully powered off (and you did turn off the power strip) and this battery is [near] empty then these things will reoccur. – Hennes Oct 15 '15 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.