6

I'm not sure why this happened but I am no longer able to click and drag to highlight text in Google Chrome.

Using:

Google Chrome Version 41.0.2272.76 (64-bit)

OS:

Linux Kali 3.18.0-kali3-amd64 #1 SMP Debian 3.18.6-1~kali2 (2015-03-02) x86_64 GNU/Linux

The cursor changes from an arrow to the I-cursor and double clicking to highlight works, as well as holding shift & ctrl, but when I click and drag, the text does not highlight.

Can anyone help?

  • Same problem with Kubuntu 14.10 64bit + Chrome 41.0.2272.89 (64-bit). Double clicking on text DOES select it. Also moving the scroll bar doesn't work either. – Angelos Pikoulas Mar 17 '15 at 14:16
  • I'll add that I'm having this problem on a Ubuntu VM, and in general all "hover" events are not working. Hovering over text doesn't change the cursor, hovering over elements in the page doesn't fire events, etc. Right clicking or scrolling with the cursor over the element seems to cause the events to fire. It seems to be a problem with Chrome v41, didn't have this problem before updating. – agent86 Mar 17 '15 at 15:12
1

I had this problem in Chromium and Chrome when running in VirtualBox. Disabling mouse integration got it working for me.

There appear to be several related bugs https://code.google.com/p/chromium/issues/detail?id=465660

1

As @Jeremy mentioned in one of the comments, this issue happens when using Chromium inside a virtual machine. One fix that worked for many people is to edit file /usr/share/applications/google-chrome.desktop.

Everywhere you see a line starting with Exec=, add the --touch-devices=123 parameter in the command line. For example:

Exec=/usr/bin/google-chrome-stable %U

becomes

Exec=/usr/bin/google-chrome-stable --touch-devices=123 %U

Once you have made the changes, make sure you close all instances of chrome processes currently running:

sudo killall chrome

The changes should take effect after Chromium is restarted.

  • This works well enough, but it's still a bit spotty. – Seiyria Apr 25 '15 at 16:20
  • Wow, this works! @Seiyria - did you find anything that doesn't work? – Richard de Wit Jul 1 '15 at 4:54
0

You can also edit /usr/bin/chromium-browser so that this option will be present at default. Open the file in a text editor and edit the following line: CHROMIUM_FLAGS="${CHROMIUM_FLAGS} ${PLUGIN_PARAMETERS}" to look like this: CHROMIUM_FLAGS="--touch-devices=123 ${CHROMIUM_FLAGS} ${PLUGIN_PARAMETERS}"

Now chromium will be launched with the --touch-devices=123 parameters regardless of how it is launched.. thats the way I prefer it anyways :P

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.