5

Scenario

My NAS drive (a Synology DS214+) not working on a domain, with multiple clients connected on the domain.

Network drive mounted and can be accessed, however copying files gives the following error:

enter image description here

This error was not present when the NAS drive was part of the domain, however this is no longer possible.

Question

1: Am I right in assuming that this error is because the NAS drive is not part of the domain, and the domain client is trying to access files?

2: Is there any other option to fix this other than rejoining the domain?

Update

  • Mapping via the IP address or hostname makes no difference
3
  • If you're using the NAS's host name to map it, try using the IP instead (or vise versa). Mar 9, 2015 at 13:14
  • Same error with both
    – Sarima
    Mar 9, 2015 at 13:19
  • This question is actually a duplicate of this one.
    – Vinayak
    Mar 12, 2015 at 4:26

1 Answer 1

6
+100

To answer your questions...

  1. Am I right in assuming that this error is because the NAS drive is not part of the domain, and the domain client is trying to access files?

    This error is probably caused by Windows thinking you're copying stuff from the Internet and not the intranet and depending on the security settings for the zone (probably the Launching applications and unsafe files setting?) it is prompting you to confirm the transfer.

    Internet security settings

  2. Is there any other option to fix this other than rejoining the domain?

    Yes. Add the IP address of the NAS drive to the Local Intranet zone. Bring up Internet Options by pressing Win+Rcontrol /name Microsoft.InternetOptionsEnter

    Then follow Jeff Atwood's instructions:

    • Click Security tab.
    • Click Local Intranet
    • Click Sites button.
    • Click Advanced button.
    • Enter the IP Address of the other machine or server (wildcards are allowed) and click Add
    • Click Close, then OK, then OK again.

      Add to local intranet
4
  • 1
    The 2nd part fixed the issue, however the PC doesn't have the prompt option ticked as per the 1st part.
    – Sarima
    Mar 12, 2015 at 9:16
  • @JB_STWUK I'm not really sure it's related to ur problem. What option did you have selected?
    – Vinayak
    Mar 12, 2015 at 9:21
  • Enabled was selected
    – Sarima
    Mar 12, 2015 at 9:32
  • @JB_STWUK I see. I'm not really sure which security setting results in that prompt. It might be this one but it doesn't matter once you've added your NAS drive to the local intranet zone.
    – Vinayak
    Mar 12, 2015 at 14:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .