2

I'm having a problem logging into xfce under Arch Linux.


Problem:
After logging in (with Slim like I usually do), I get this error message:

Unable to load a failsafe session
Unable to determine failsafe session name. Possible causes xconfd isn't running (D-Bus setup problem);
environment variable $XDG_CONFIG_DIRS is set incorrectly (must include "/etc") or xfce4-session is installed incorrectly.


Fixes that did NOT work:
I found these fixes on Google, but none of them worked for me.
1. Make sure $XDG_CONFIG_DIRS is set correctly:

export XDG_CONFIG_DIRS=/etc/xdg

2. Make sure everything in my home directory has correct permissions:

sudo chown -R $USER $HOME

3. Change permissions of /etc/xdg:
(I later realized that this must be an old fix because Arch recommends 755 permissions for /etc/xdg, NOT 644)

sudo chmod 644 /etc/xdg

4. Try to start an xfce session manually:
(because this did not work, I know that the problem is with xfce and not SLIM)

startxfce4

5. Total reinstall of all xfce apps:

yaourt -Sa $(yaourt -Qsq xfce) 

6. Remove xfce config and then reinstall everything (in order to make sure that xfce settings are reset to default)

mv ~/.config/xfce ~/.config/xfce.bak
yaourt -Sa $(yaourt -Qsq xfce)

7. Deleting session cache:

rm -r ~/.cache/sessions/


I'd list the output of yaourt -Qsq xfce if I could, but I'd need to login to my computer in order to copy and paste it.

6

The way work for me is to replace exec startxfce 4 by dbus-launch xfce4-session

The xstartup file looks like the following:

 #!/bin/sh
 unset SESSION_MANAGER
 unset DBUS_SESSION_BUS_ADDRESS
 dbus-launch xfce4-session
1
  • Only this variant worked for me on Debian 10, thank you bro! – Fr0sT Jul 10 '20 at 12:26
1

Don't use slim. It's outdated and doesn't support logind and other systemd stuff on arch. Use lightdm with the gtk greeter instead (official Xfce-IRC-help-channel recommendation).

Alsoxfce4-session-develis outdated in favor forxfce4-sessionsince the 4.12 release. I will updatexfce4-session-develas soon as a >4.12 development version is released.

0

I found out that the problem was with xfce4-session-devel. The latest update doesn't work on my system. Installing the stable xfce4-session package would have been the correct fix:

sudo pacman -S xfce4-session

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.