1

I have an Acer notebook and wanted to upgrade an SSD. So I created a bootable USB, took the old HDD out and the new SSD into the primary slot. Installed Windows 8.1 on the Samsung EVO and started the PC to try it. It worked perfectly, but because I still need all the data from my old HDD I cannot clear it. So I plugged it into a second slot, and now the problem is the PC keeps booting from old HDD, even though I told the boot menu to use SSD first.

Then again looked into boot menu and it automatically set old HDD as first and doesn't even list the SSD anymore. But I see the SSD in the explorer.

Can you help me so my laptop will simply boot from the SSD without deleting the old HDD?

  • Did you set the boot menu in bios or on the SSD? Would setting the boot menu on the HDD to default to the SSD help? – jdh Mar 9 '15 at 18:08
  • In the bios. I set the SSD as first, but it automaticly got rid of that. Is it possilbe to deactivate the ability to boot from the hdd but still keep all data? – Hannes Mar 9 '15 at 18:18
  • Use a boot manager like grub? – Raystafarian Mar 9 '15 at 18:32
  • Why? Isn't that was the bios boot order is for? Is there now way of just deactivating the hdd as bootable? – Hannes Mar 9 '15 at 18:38
  • Yes you can effectively disable the hdd booting and keep all the data. When the hdd boots next, run 'msconfig" and go to the boot tab. Instead of deleting all entries, just set it to boot the SSD and remove the HDD. Next time it boots, if the HD boot manager starts up, it will jump over to finish booting on the SSD. – jdh Mar 9 '15 at 20:25
1

You have to press the hotkey when you see the BIOS splash screen before Windows even begins to boot to get into Setup. Often the key is F1 or F2, but sometimes it is the Delete key. Somewhere in those menus you need to change boot order in BIOS to boot the SSD instead of your hard drive.

I recently did that with my laptop. I installed Linux with its boot loader on an mSATA SSD card, then set BIOS to boot that instead of Win7. However, if it is a Windows 8/8.1 computer it might be using UEFI with secure boot instead of legacy BIOS and you might also need to disable "secure boot" in Setup. But I cannot be certain of that because I do not have any Win8 computer at home and have not modified the drive on my work PC (but did try a live Linux system on it booted from USB memory stick).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.