0

I'm attempting to cross compile libvorbis ready to then do the same for libvpx to ultimately compile a windows version of ffmpeg that can handle WebM (along with a few other options that I've yet to move onto).

I'm currently following the guide from the WebM Project wiki here yet I'm running into problems with libvorbis (1.3.3). When running ./configure --prefix=/mingw --target=x86_64-win64-gcc I'm getting back the following with an error:

checking build system type... i686-pc-mingw32 checking host system type... i686-pc-mingw32 checking target system type... Invalid configuration x86_64-win64-gcc': systemgcc' not recognized configure: error: /bin/sh ./config.sub x86_64-win64-gcc failed

libogg completed just fine with no problems by using the same configure command so I'm pretty sure my setting on the --target should be fine as I'm assuming this is a standard setting for most configure commands when cross-compiling using MinGW.

My question is really, what could be causing this and any ideas how I can correct the issue?

  • Were you able to compile yasm using the supplied instructions? – Ramhound Mar 11 '15 at 12:16
  • It might also help if you use the current stable version instead of 1.3.3 although its unlikely to make a difference. – Ramhound Mar 11 '15 at 12:31
  • @Ramhound I'll give it a crack but I'm using the one they recommend on the WebM wiki. – Elliot Blackburn Mar 11 '15 at 13:31
1

Had the same problem as above, and found a workaround for it, try:

 ./configure --prefix=/mingw --target=x86_64-mingw64
  • I'm afraid I've moved on from this task quite a while ago, we ended up outsourcing all of this block of work (sadly, it was quite fun). I'll mark your answer as correct as it seems sensible, should work and may help others. But for future reference of people with this problem, I never found any other solution to the problem. – Elliot Blackburn Nov 6 '15 at 14:57
1

The accepted answer is a correct workaround, but note that it does not work with the 1.3.3 version of libvorbis the original wiki article recommends. Using libvorbis 1.3.5 with the above answer works.

Also note that the wiki's ffmpeg instructions also are obsolete. This works as of 2017:

./configure --prefix=/mingw64 --arch=x86_64 --pkg-config=pkg-config --target-os=mingw64 --enable-libvpx --enable-libvorbis

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.