1

We have 3 Windows 8.1 PCs setup. On one of the PCs we have shared a directory. On the other 2 machines, we define a drive letter to access

net use h: \\computer1\hfolder (user and pwd) /persistent:yes

On all 3 machines, we can access H: via the command shell without a problem.

On only 1 of 2 client machines, we can use the h: in Explorer directly and browse the files

On only 1 of the 2 client machines, we can use the UNC path in Explorer directly (e.g. \\computer1\hfolder) and browse the files

In code on the bad PC, we cannot use the UNC path, but can use H: to access files.

Any idea what setting is messed up on the 3rd 'special' client PC?

closed as too broad by Ƭᴇcʜιᴇ007, DavidPostill, mdpc, Nifle, agtoever Mar 23 '15 at 15:26

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Is UAC enabled? Do you map these drives with an elevated command prompt? – Daniel B Mar 11 '15 at 15:16
  • We mapped the drives w/ 'net use' elevated and have the same UAC settings on the machines – kenny Mar 11 '15 at 15:19
1

Elevated processes essentially run in a separate session. Non-elevated programs do not have access to their resources. This also means that when you map a connection in an elevated command prompt, it won’t be available to non-elevated applications at all. By default.

Whether or not mapped network drives (or even sessions, especially noticable with password prompts) are shared between the regular and elevated session is controlled by a registry entry. To enabled shared connections, import this .reg code:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"EnableLinkedConnections"=dword:00000001
  • Sounded plausible, but it doesn't seem to be the whole solution for this PC. Thanks! – kenny Mar 11 '15 at 19:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.