2

I installed zfs-on-linux to my virtual Ubuntu LTS server years ago via PPA. The system resides on a VMware Workstation 10 in Windows 8.1.

The working ZFS/SPL versions installed are 0.6.3. It has endured a few OS upgrades from earlier LTS's to 14.0.2 LTS. My zfs pools host /home, /var/www, and other data directories that shouldn't be part of the boot process. I recently cleared some unused kernels and kernel sources with apt-get autoremove. At reboot, the system hangs at:

screenshot at startup

Scrolling back, I see some potential errors:

[   17.287100] EXT4-fs (sda1): INFO: recovery required on readonly filesystem
[   17.287190] EXT4-fs (sda1): write access will be enabled during recovery
[   17.297142] EXT4-fs (sda1): recovery complete
[   17.297810] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)

If I reboot to recovery mode, do zfs mount -a, and resume booting, everything works fine, until I need to reboot again. One strange behavior in the recovery mode is that zfs list (after zfs mount -a) won't show the datasets as mounted even though they are mounted. I think it's because the root filesystem (on /dev/sda1) is still in ro mode.

I also tried:

  • fsck /dev/sda1 -- It reports the FS is clean, and this step does not solve the problem.
  • Completely purge zfs from system with dpkg --purge using this guide . In this case the system can reboot to login prompt (There's no GUI) without problem, but I can't use zfs. As soon as I re-install ubuntu-zfs and reboot, the system gets stuck at the same spot.
  • Install another version of Linux kernel and headers. I've tried 3.16.0-31-generic. My other working systems with zfs have 3.13.0-35-generic and 3.13.0-44-generic, so I also tried them. Result: Same problem.

Any ideas on this problem or how to continue the investigation?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.