4

i have a weird issue that started happening a few days ago, for no reason (no new software was installed or windows update was done when it happened the first time).

Just like most people, i rarely shut down my pc, i just put it to sleep till i need it. My problem is that lately, my internet connection has been practically useless when i wake it up, i'm forced to restart the computer if i want to be able to use internet without issues.

When it wakes, it reconnects to the router without problems, it says there's internet but browsers, steam, etc cannot connect to the internet, i can't even ping the websites from the cmd but weirdly enough, skype sometimes still works when that happens. I can't even access the admin web page of the router i'm connected to (the 192.168 something)... I dont think it is the router since its only this pc that has this issue (other devices work fine), plus i've hard reset it and i still had that issue when the router was again up and my pc connected to it.

Also, reconnecting or even removing and plugging in the wifi adapter again doesn't do anything, it connects to the router, says theres internet but i still have that issue.

Even stranger is, if i wait long enough ( 5-10 minutes), it magically starts working fine and i can access websites and do stuff normally, sadly its not permanent and only lasts for a couple dozen minutes before starting acting weird again, the process then repeats (works, stops working...).

Its really annoying because its such a weird issue and the only solution i have for now is to shutdown the pc instead of putting it to sleep.

Any tips?

Thanks

9
  • What's a "wifi pen?"
    – Vinayak
    Mar 13 '15 at 18:42
  • its just like a pendrive, but used to access wifi, i build a custom build pc a couple of years ago, sadly i forgot the pci wifi so i had to buy that usb pen. Mar 13 '15 at 18:45
  • Do you mean a USB Wi-Fi adapter?
    – Vinayak
    Mar 13 '15 at 18:48
  • well.. yeah, is just that we call it pen (anything that connected to the oc and looks like a pendrive is a pen to us here in portugal) coisas.com/… Mar 13 '15 at 18:50
  • I see. I'm inclined to think it's a driver issue. Do you have power saving enabled for the wireless adapter?
    – Vinayak
    Mar 13 '15 at 18:52
3

I Turned the power setting OFF (i.e. UNCHECKED the "turn off the device to save power" setting) and it is now working fine.

To answer Scott's comment and anyone looking for this setting, this is how to reach it:

  1. Device Manager

  2. Network adapters

  3. Double-click the adapter pertaining to the network connection of interest

  4. Click the Power Management Tab

  5. UNCHECK "Allow the computer to turn off this device to save power"

This is the same answer Brian gave the next day. I am performing some tests to see if it speeds up reconnection to the Internet after waking up from sleep.

2
  • 1
    Where is that setting? Please do not respond in comments; edit your answer to make it clearer and more complete.
    – Scott
    Jul 23 '17 at 8:01
  • This is the correct answer. Unchecking the box prevents the adapter from being put to sleep. Otherwise the adapter will need to refresh itself by going through the DHCP process and requiring a new dynamic IP address each time it wakes up. Same thing as performing an IPCONFIG / RENEW at the command prompt. While unrelated to the primary issue, it may also be worthwhile to check the Advanced Power Settings from the Control Panel and ensuring that the wireless adapter is set to max performance. May 17 '18 at 22:37
1

I had the same problem as described with my girlfriends laptop last year. I fixed it by going to the network connections folder, and adjusting the properties of the wireless network connection. In properties, select configure. And then under power management, make sure that the computer is allowed to turn off the device to save power. Seems counter-intuitive, but that's what it was.

Hopefully it's the same for you. Good luck.

5
  • 1
    A gave this a +1, however it may only be 'partially' correct. This area is almost certainly the cause of the OP's issue, however I have experienced the same scenario in the past, but only after 'enabling' this setting to allow the device to be turned off. I turned this feature back 'off' and the issue was resolved. The cause of my internet taking so long to reactivate was due to power management shutting it off. Obviously, it takes a few minutes for the NIC to reconfigure itself every time it comes back on. Make sure this feature is 'disabled'. Mar 13 '15 at 19:09
  • OK, for now it seems to be working, i'll give it a couple of days then set the question as answered Mar 14 '15 at 19:35
  • update, this morning i had the same issue again, it seems that it didn't fix it :( Mar 19 '15 at 11:42
  • @JoshCampbell I had the same issue and "disabling" the setting (AKA un-checking the box) resolved it. Do you think it would be correct to edit the answer because the OP made a typo?
    – Guy
    Mar 5 '18 at 22:01
  • Actually Sri's answer is the correct one. And well written I might add. Looking at this now, I'm not really sure why I didn't correct it back in 2015. Sorry, must have been pressed for time. May 17 '18 at 22:32
1

To access the "Network Connections" folder, click on the Windows Start button and enter "Network Connections" in the search field. Select "View Network connections. Right click on one of the connections listed, choose "Properties." In the window that appears, click on the "Configure" button. Then click on the "Power Management" tab. Deselect the checkbox for "Allow computer to turn off..."

If the checkbox is already deselected, selecting it and pressing OK, then returning to deselect it may fix your problem.

However, as suggested in other comments, this may or may not fix your particular problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.