0

I run Windows 8 via Bootcamp on a 15" Macbook Pro Retina (with Nvidia GT750M). When I open any game that runs full screen, the game will typically force itself to use native resolution (2880x1800) or in some cases pick some extremely low resolution, instead of using whatever I have set via Windows' display settings. If I attempt to set the resolution in-game to, say, 1920x1200, or anything other than native Retina, I end up with a full screen game in a black-bordered box, actually scaled down to those physical pixels instead of being scaled up to fit the entire screen.

I have used DPI scaling in every conceivable configuration, tried forcing the resolution via Windows after starting a game, etc. I have searched relentlessly for a fix for this issue but have found nothing that works for me. HELP!

1

I solved my own problem, but I'd like to post the solution for anyone else who may come across this issue, as I don't believe I'm the only one who's ever had this problem.

The issue is that when running Windows via Boot Camp, the Retina display is reported at its full resolution (2880x1800). This results in really tiny things on screen until the proper DPI is set manually or the resolution is lowered (leading to a muddy/fuzzy desktop). Regardless of the set resolution, perhaps due to DirectX allowing Windows display settings to be bypassed, full-screen programs can grab the Retina display's native resolution and adjust to fit it in all its eye-pleasing glory.

The problem here is that the (as of March 2015) Nvidia GT750M chip has nowhere near enough muscle to power almost any game at any reasonable level at the highest resolution (for instance, in a recent test, even on the lowest video settings Crysis 2 ran at a paltry 15ish fps). At 1920x1200 the GPU can still choke on some things, although for the most part I've found most recent releases can hit 60fps at medium-high settings.

The sensible thing to do here is of course to lower the resolution to 1920x1200. When you do that, some games get it right: scale to fit the entire screen; but most games simply throw up some nice black bars and you're left with about half the screen to play in. No amount of playing with Windows' display settings will fix this.

The solution:

Right-click on the desktop and select the Nvidia Control Panel. On the left column select "Adjust desktop size and position", and in there you'll find a checkbox option labeled "Override the scaling mode set by games and programs". Selecting this will stop games from displaying lower resolutions such as 1920x1200 at 1:1 ratio, and instead allow the GPU to fill the entire display.

Note that this solution is specific to Retina MacBook Pros running Nvidia chips; I have no idea if this will work for other displays on Nvidia chips having similar issues, although I have a strong suspicion that it will.

0

Above answer still works on 2018 MBP. Setting is in the AMD control panel. turn on GPU scaling and then the menu to the right you can pick full screen or aspect ratio.

1
  • Welcome to Super User! Please don't post an answer to confirm that another answer worked. The site's Q&A format reserves answers for solutions to the question, and each answer should contribute another solution. The way to indicate that an answer was useful is to invest a little time in the site and you will gain sufficient privileges to upvote answers you like. With a little additional rep, you will also be able to post comments, which can be used to add clarifying information. Or, you can propose an edit to the other answer to add updated info. – fixer1234 Jul 28 '18 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.