0

I have currently gotten my parts for my new home-build server, but I've come into an error installing CentOS 6.6 (minimal 64bit). I am installing 6.6 instead of 7, due to OpenVZ not supporting CentOS 7 yet.

I have used the official mirror, and used one in my country. I did also, just to make sure, check the checksum with both my local copy, the remote copy and a few other random mirrors, all checked out fine. The whole installation goes fine, untill it begins to install (right after you choose the installation target). It says

Unable to read package metadata. This may be due to a missing repodata directory. Please ensure that your install tree has been correctly generated.

Failure: repodata/6e147c9aea5bf4c0f1ba7ecf759ddd3a259003a7f12a5a74398c9f05d672573d-primary.sqlite.bz2 from anaconda-CentOS-201410241409.x86_64: [Errno 256] No more mirrors to try.

To make sure this was not a networking issue, I have tried changing cable (with a cable I know works), rebooted multiple times, added a Ubuntu LiveCD to check if networking worked there and the back ports is lighting green and flashing orange. My router also registers the computer. I also tried re-installing the USB multiple times, no luck.

I am unable to access terminal, at least I do not know how to - so I cannot execute

yum clean

and similar commands.

  • As a workaround, you could use a full install CD, if available. – Daniel B Mar 14 '15 at 18:17
  • If you mean LiveDVD, I am looking into converting those two ISO's into one. However, CentOS seem to have deleted the LiveCD for their 6.6 – Gasur Mar 14 '15 at 18:20
  • Works for me. ;) – Daniel B Mar 14 '15 at 18:55
  • I cannot see any liveCD in that, however I tried installing with the DVD, same error. Tried using a different USB maker (unetbootin instead of universal USB installer), no luck either. – Gasur Mar 15 '15 at 12:32
  • I see. Did you try this? – Daniel B Mar 15 '15 at 12:34
2

Well, I found this blog post, which seems to help solve the problem. It quotes this Stack Overflow question.

Rename files on ISO file or Flash-BOOT-USB in PATH: G:\repodata\

0dafccfdbf892f02acca8267ade4bdcee7280a682e65dc7e29145f3341fd7a8c
5af8199bd0ffb441c34ef946582d0d06c1ad770755e631690771e0bceb0ad222
6ac72f497df511cc2dc584eaa59779884fc572c1618e7c62dbd631ab8babf53d
495d3964f864fbab835ea1afb8a5272352cd12ded13d607205109fefaddd0ab6
594d4bb4a79ed01d66635adbcf76c45ca4a85b30fc3e3c3c28316e64f0a83f21
b4e0b9342ef85d3059ff095fa7f140f654c2cb492837de689a58c581207d9632
ca525c73086186bfcb81ad9edd45796026dac7e4e50524e0f2daf901532aaf66
fdd542ef36b0cde54ee0521fae90b98911db06483163aa1c049995b6d109349b
repomd.xml
TRANS.TBL

to

0dafccfdbf892f02acca8267ade4bdcee7280a682e65dc7e29145f3341fd7a8c-primary.sqlite.bz2
5af8199bd0ffb441c34ef946582d0d06c1ad770755e631690771e0bceb0ad222-other.xml.gz
6ac72f497df511cc2dc584eaa59779884fc572c1618e7c62dbd631ab8babf53d–filelists.xml.gz
495d3964f864fbab835ea1afb8a5272352cd12ded13d607205109fefaddd0ab6-primary.xml.gz
594d4bb4a79ed01d66635adbcf76c45ca4a85b30fc3e3c3c28316e64f0a83f21-filelists.sqlite.bz2
b4e0b9342ef85d3059ff095fa7f140f654c2cb492837de689a58c581207d9632-c6-x86_64-comps.xml
ca525c73086186bfcb81ad9edd45796026dac7e4e50524e0f2daf901532aaf66-c6-x86_64-comps.xml.gz
fdd542ef36b0cde54ee0521fae90b98911db06483163aa1c049995b6d109349b-other.sqlite.bz2
repomd.xml
TRANS.TBL

The actual file names may very as newer versions of the files become available. Expected file names are contained in the repomd.xml file. Since the first part of the file name stays the same, you can use it to find the associated entry in repomd.xml.

And if you don’t like XML, you can also use TRANS.TBL, it also contains the complete names.

As for the reason: The first part of the file name already maxes out the length Windows can support via Joliet—64 characters. As such, complete file names are only visible when using a tool that supports the Rock Ridge extensions. Like Linux, naturally. ;)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.