0

I am trying to run a BIOS update using /forceit command after the file name on a Dell Inspiron with a 'faulty' battery (BIOS update on Dell requires 10% battery, hence why I cannot perform this) . I keep getting the following error message:

error: unknown command.

This command should allow me to update the BIOS. Updating the BIOS is my last resort as I have tried practically everything. Is there a way to run this command?

  • Have you reached a solution? – mowienay Jun 11 '16 at 20:39
  • this isn't even any paramter of any command native to any windows version, it's particular to some dell thing apparently, according to peter – barlop Nov 12 '16 at 12:39
1

/forceit is not a command of its own, you need to use it as a command line parameter like DellBIOSUpdater.exe /forceit.

  • thanks for your reply. I did use it like that.. C:\'file_path'\filename.exe /force it, however I still get the error: command unknown – joebegborg07 Mar 15 '15 at 7:58
  • 1
    Don't put parts of the path in 's and don't separate the words 'force' and 'it'. You need to be precise, or Windows won't know what you mean. – Peter W. Mar 15 '15 at 13:24
  • I'm positive I'm writing it correctly. Is it possible to update BIOS using hirens boot cd ? – joebegborg07 Mar 15 '15 at 13:54
1
  • Make Bootable FreeDOS USB Drive personally I used Rufus Portable.
  • Copy the BIOS EXE File. Mine was 3442A14.exe for Inspiron 3542.
  • Restart computer and press F12 at boot logo.
  • Boot the USB Drive.
  • DOS window should appear now type the first letter of the filename and then press tab or type the full name of the file followed by /Forceit
  • Press Y to continue update. Update should prepare files the restart and then start updating with percent bar repeated several times and then restart to start Windows with BIOS updated.
  • When I try from FreeDOS (and MSDOS 6.22), I get the error message: - Error: Unable to start a Secure Flash session. – reukiodo Jul 21 '19 at 10:42
  • Using a hint at forums.lenovo.com/t5/ThinkCentre-A-E-M-S-Series/… , I was able to update from A02 up to A13 successfully, and then up to the current A16. – reukiodo Jul 21 '19 at 11:58
-1

I have an Acer Aspire ES1-111 which battery cannot hold any charge, I checked battery capacity using "powercfg -energy" and it showed that the battery still has its full capacity so I guess it must be bios problem.

I downloaded the latest bios update but it showed an error "cannot continue because battery juice under 15%" or something like that.

Tried /forceit command parameter to no avail.

After digging deep I finally found a solution here on Super User:

  1. Download the BIOS update from Acer site (ZHK116.EXE)
  2. Run the downloaded file, you will get an error like "No battery" or "Low battery", stay on the error dialogue (!)
  3. Navigate to your current users temp directory (e.g. Users/<username>/AppData/Local/Temp), there should be somewhere a temporary directory containing the extracted files from the EXE file (for me it was 7zS4A88.tmp)
  4. Save the contents of that temp directory somewhere (you can then close the error dialogue, the temp files will be removed)
  5. Open the file platform.ini with a text editor and search for the key "AC_Adapter"
  6. Change parameter BatteryCheck from 1 to 0 or just leave it empty (this disables battery check during BIOS update preparation!), save the file
  7. Run InsydeFlash.exe in the same directory
  8. That's it, bios update should start now
  • -1 see peter's answer at least he mentions that it's a parameter to a command that is a dell thing – barlop Nov 12 '16 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.