I'm having issues booting from USB on my Surface Pro 2 with win 8.1 and UEFI. Tried creating bootable USB using LinuxLive and a Linux dist. Also tried creating bootable USB with Easy2Boot, and adding Linux dist. I've tried Rufus too. They are partitioned as FAT32. It's like the USB is skipped. Nothing happends. I've tried disabling Secure Boot. There's no legacy option in UEFI setup. Tried different sub solutions to the two main ones I've mentioned. I'm only interested in running the Linux dist. Not install it. What could it be that is hindering me in booting from USB? I've tested the USB in another laptop, where it works fine.



  • 2
    Do you have another UEFI system where you could verify that the USB drives you prepared are, in fact, UEFI-bootable? – Daniel B Mar 15 '15 at 0:04
  • have you tried other bootable usb sticks linux aside? like a windows 7 usb? (I doubt OS in itself would make a difference but anyhow) and other models of stick? – barlop Mar 15 '15 at 0:09
  • A lot of specialty tools to create bootable USB drives from Linux images do not create EFI-bootable images. In most cases, the safest approach is to use dd to copy the image directly to the target disk, as in dd if=image.iso of=/dev/sdc. If this isn't possible, read the documentation for whatever tool you're using and/or peruse its menus to be sure you're creating an EFI-bootable flash drive. – Rod Smith Mar 15 '15 at 17:36
  • I've tried in my Dell Venue 8 Pro too. No luck (disabled Fast Boot and Secure Boot). I tried the USB key in another (non UEFI) PC, where it worked, so I guess the USB key is okay. I have no other bootable USB's, so can't try other. – Frank Mar 15 '15 at 20:14
  • You can test UEFI booting from a USB drive using Virtual Box and VMUB utility. See RMPrepUSB.com Tutorial #4 – SteveSi Mar 16 '15 at 10:42

hold the Volume Down key on the Surface Pro and click power Key

when surface logo comes ,free your hand

this will boot from your usb devices

|improve this answer|||||

Some systems do not support Legacy\CSM\MBR booting. Look in the firmware settings for these options and also disable Fast Boot. Systems with no Legacy\CSM\MBR option can only UEFI-boot. LinuxLive and E2B are for Legacy\CSM\MBR booting systems.

If you have a linux distro that you want to UEFI-boot: 1. Format a FAT32 USB drive using RMPrepUSB - Boot as HDD 2. Extract all the files from the ISO and copy them to the USB drive - you need to see a \EFI\boot\bootx64.efi file for UEFI-booting to work.

or use Rufus to prepare a UEFI-bootable (single-boot) USB drive from the ISO

For a multiboot USB drive, you can use Easy2Boot, but you will need to convert each ISO into a .imgPTN file and then boot to Easy2Boot using an MBR system or a VM (e.g. RMPrepUSB - QEMU) and then select the .imgPTN file. This converts the Easy2Boot USB drive to a UEFI-compatible partition. You can then boot to the linux distro from your UEFI-only system.

|improve this answer|||||
  • How about "Bootloader Options" in RMPrepUSB? Tried BOOTMGR and SYSLINUX. None of them gives me the \EFI\boot folders. – Frank Mar 15 '15 at 20:16

The EFI files must be in the source files - e.g. CloneZilla contains both 32-bit and 64-bit UEFI \EFI\boot\bootxxxx.EFI files. If the ISO does not contain the EFI file(s) then it does not support UEFI-booting. You cannot UEFI-boot to a payload that does not have the UEFI boot files and was not written to support UEFI booting. If the source contains \EFI\boot\bootx64.efi then it should boot from a 64-bit UEFI system. If it contains \EFI\boot\bootia32.efi then it should boot from a 32-bit UEFI system. If it contains neither file, then it does not support (x86) UEFI-booting.

|improve this answer|||||
  • Ohh, that was was helpful. I will have to look in to this, to determine where I am with this. Tank you. – Frank Mar 17 '15 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.