2

Without VirtualBox guest additions installed, the only screen resolution is 640x480:

$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
   640x480       73.00* 

How can the resolution be set to 1280x1024, for example? No VirtualBox guest additions should be necessary.

The guest is a Fedora system.

I've tried adding an Xorg config file as described by this Whonix article, which did exactly nothing.

Using cvt to get a new modeline for xrandr does not seem to work either:

$ cvt 1280 1024
# 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
$ xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr: Failed to get size of gamma for output default
$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
   640x480       73.00* 
  1280x1024_60.00 (0x1bd) 109.000MHz
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock  63.67KHz
        v: height 1024 start 1027 end 1034 total 1063           clock  59.89Hz
$ xrandr --addmode default 1280x1024_60.00
xrandr: Failed to get size of gamma for output default
$ xrandr --output default --mode 1280x1024_60.00
xrandr: Failed to get size of gamma for output default
xrandr: Configure crtc 0 failed
  • I am not in front of a VB installation but as far as I recall, you need to install the DKMS module from the Guest Additions if you want higher screen resolution. – fpmurphy Mar 15 '15 at 17:57
  • I wrote that I don't want guest additions. – basic6 Mar 15 '15 at 18:33
  • Not possible to do without guest additions. – fpmurphy Apr 4 '15 at 11:08
1

1) Stop XOrg

 stop REPLACEWITHNAMEOFXORGSERVICE

2) Open console

CTRL-ALT-F1

3) Create default xorg.conf, it not exists

X -configure

4) Move xorg.conf.new so system uses config file

mv xorg.conf.new /etc/X11/xorg.conf

5) Reboot

reboot

6) Modify xorg.conf, add

Section "Monitor"
...
 HorizSync 1.0 - 1000.0
 VertRefresh 1.0 - 1000.0
 Option "MinClock" "1.0"
 Option "MaxClock" "10000.0"
 Option "Primary" "True"
 Option "PreferredMode" "1920x1080"
...
EndSection

7) Reboot

reboot

8) System Settings > Display > "Select Any -4:3- Resolution"

9) Enable widescreen

Host:VBoxManage setextradata "YOURGUEST" "CustomVideoMode1" "1920x1080x32"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.