7

After some updates to fedora in the last few years, I've been getting the following popups (one when I login and one when ever I start google-chrome)...

"Choose password for new keyring"
"An application wants access to create a new keyring called 'Default'. Choose the password you want to use for it."
enter image description here

(If I've then created "Default") "Enter password for keyring 'Default' to unlock"
"An application wants access to the keyring 'Default', but it is locked."
enter image description here

I don't want to use a password manager and would like to never have these popups. How can I remove or disable them? I do not have root access, so I'll need some kind of per-user config I can set.

Many related questions assume I'm using ubuntu, e.g.: Why do I need to enter a password for the Default Keyring to unlock?, and I haven't found anything that works for fedora.

  • 1
    the ultimate solution is rm -f /usr/share/.local/keyrings/* then remove or disable gnome-keyring from packages however if this is only at boot and chrome launch this lends me to believe you are backgrounding chrome and it is asking for 1 of 2 reasons. 1) chrome is NOT saving the config in the singleton cookie OR 2) for some reason gnome-keyring is not properly saving it. – linuxdev2013 Apr 14 '15 at 22:43
2

Setting this keyring to blank should let it do its thing without bothering you. If you have already set it up, trash your keyring and restart Chrome to receive the fresh prompt (where you can set it to not use a password).

Check the following locations for the keychain:

  • ~/.gnome2/keyrings/default.keyring
  • ~/.local/share/keyrings/*

More elaboration and links at my Unix SE post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.