2

For several months now my Windows 8 system (German Windows 8, 32bit) fails to install the system updates; the last one which successfully installed was KB2918614, at 2014-09-14 (security update for Windows 8). All further updates failed; as of now, there are 55 updates waiting. I tried every now and then, giving the self-repair its chance; now that my desktop system has another problem, I want to get my laptop updated, at last.

The system tries to configure the updates; after 98%, it says

Fehler beim Konfigurieren der Windows-Updates.
Änderungen werden rückgängig gemacht
Schalten Sie den Computer nicht aus.

which can be translated as (I don't know the exact wording of an English version):

Error configuring the Windows updates.
Changes are being reverted
Don't switch off the computer.

I had a look at the event protocol and found the following updates (sorted for looking them up and uncheck them in the system updates control):

KB2973501
KB2979571
KB3003743
KB3011780
KB3034344
KB3035017
KB3039066

... which all failed with an 0x800F0922 error.

I unchecked the failed updates and tried again, hoping this would work and I'd be able to install them after a first successful step. This failed; this time there were even more errors.

I tried some repair of the updates database ("Windows Update", "Problembehandlung"):

  • Potentieller Fehler der Windows Update-Datenbank erkannt: 0x80070490 (behoben) (probably "possible error of update database found: 0x80070490 (fixed)")
  • Windows Update-Komponenten müssen repariert werden (behoben) (probably "update components need repair (fixed)")

After that, the system had forgotten about all previously installed updates:

  • Updates wurden zuletzt gesucht: nie (updates seeked last time: never)
  • Updates wurden installiert: nie (updates installed: never)

I tried the installation again, but no luck.

Currently I suspect the cause of the problem to show up in the following line, which occurs very frequently in the log:

  • Der Server "{752073A1-23F2-4396-85F0-8FDB879ED0ED}" konnte innerhalb des angegebenen Zeitabschnitts mit DCOM nicht registriert werden.

My translation:

  • The Server "{752073A1-23F2-4396-85F0-8FDB879ED0ED}" could not be registered with DCOM during the given time.

I have looked up Computer\HKEY_CLASSES_ROOT\CSLID\{752073A1-23F2-4396-85F0-8FDB879ED0ED} in the registry, but couldn't find anything obvious to the Windows non-expert.

What can I do to fix my update problem; any pointers? Thank you!

Edit: sfc /scannow in an admin shell seemed to do some repair, but didn't fix the problem; the update (54 updates) failed again.

Still the problem with the {752073A1...} server, and the same failed updates as above (more below some information lines which I might have missed in the first place).

I found a warning about a component AFD and an event 16001:

Die Beschreibung für die Ereignis-ID "16001" aus der Quelle "AFD" wurde nicht gefunden. Entweder ist die Komponente, die dieses Ereignis auslöst, nicht auf dem lokalen Computer installiert, oder die Installation ist beschädigt. Sie können die Komponente auf dem lokalen Computer installieren oder reparieren.

which could be translated roughly as:

The description for the event id "16001" from the source "AFD" was not found. Either the component triggering this event is not installed on the local computer, or the installation is damaged. You can install the component to the local computer or repair it.

Additional information, stored with the event:

\Device\Afd
\Driver\tcpipBM

Update: Windows wanted to install 44 updates when I rebooted, and one seems to have succeeded: KB2976978.

  • 1
    First step. Run SFC. Second Step. Run DISM. Between these two tools they will fix any integrity problems. You might want to think about installing Windows 8.1 the system corruption might be severe enough that it cannot be fixed. – Ramhound Mar 17 '15 at 13:53
  • Ok, currently running sfc /scannow in an admin shell; thank you. I have tried to install Windows 8.1, but it failed ... – Tobias Mar 17 '15 at 13:57
  • 1
    Delete or rename the CBS.log; run sfc in safe mode; then use elevated cmd prompt findstr /c:"[SR]" %windir%\Logs\CBS\CBS.log >"%userprofile%\Desktop\sfcdetails.txt" to throw the main points out to a desktop txt file - or run it on the existing file first – Tetsujin Mar 17 '15 at 17:04
  • 1
    share the complete CBS folder (compressed as zip on a cloud service). I'll take a look at the logs. – magicandre1981 Mar 17 '15 at 19:29
  • 1
    @Tobias - DISM repairs the files located within your WinSxS directory. SFC uses this directory to repair your actual system files. So if you have corruption within the WinSxS directory then SFC will fail with cryptic messages. Despite the odd choice in argument names, the DISM /Online argument, does not check the internet its references the "online system, current system, the running system" in other words the Windows installation currently running. – Ramhound Mar 20 '15 at 10:44
3

Windows fails to register ETW events for Win32k.sys:

2015-03-17 22:38:28, Info                  CSI    000000d1 Begin executing advanced installer phase 38 (0x00000026) index 126 (0x0000007e) (sequence 165)
    Old component: [ml:294{147},l:292{146}]"Microsoft-Windows-Win32k, Culture=neutral, Version=6.2.9200.17096, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=x86, versionScope=NonSxS"
    New component: [ml:294{147},l:292{146}]"Microsoft-Windows-Win32k, Culture=neutral, Version=6.2.9200.17287, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=x86, versionScope=NonSxS"
    Install mode: install
    Installer ID: {3bb9fd2b-351e-4b9c-b1fc-ed0758805998}
    Installer name: [6]"Events"
2015-03-17 22:38:28, Error                 CSI    00000001 (F) Logged @2015/3/17:21:38:28.243 : [ml:258{129},l:256{128}]"events installer: online=1, install=1, component=x86_Microsoft-Windows-Win32k_31bf3856ad364e35_6.2.9200.17287_neutral_release__."
[gle=0x80004005]
2015-03-17 22:38:28, Error                 CSI    00000002 (F) Logged @2015/3/17:21:38:28.321 : [ml:240{120},l:238{119}]"EventAITrace:Provider Microsoft-Windows-Win32k is already installed with GUID {e7ef96be-969f-414f-97d7-3ddb7b558ccc}.

"
[gle=0x80004005]
2015-03-17 22:38:28, Error                 CSI    00000003 (F) Logged @2015/3/17:21:38:28.321 : [ml:168{84},l:166{83}]"WmiCmiPlugin manproc.cpp(683): InstrumentationManifestAssert failed. HR=0x80073aa2."
[gle=0x80004005]
2015-03-17 22:38:28, Error                 CSI    00000004 (F) Logged @2015/3/17:21:38:28.321 : [ml:166{83},l:164{82}]"WmiCmiPlugin eventloghandler.cpp(192): ProcessEventsInstall failed. HR=0x80073aa2."
[gle=0x80004005]
2015-03-17 22:38:28, Error                 CSI    00000005 (F) Logged @2015/3/17:21:38:28.321 : [ml:170{85},l:168{84}]"WmiCmiPlugin eventloghandler.cpp(212): EventLogHandlerInstall failed. HR=0x80073aa2."
[gle=0x80004005]
2015-03-17 22:38:28, Error                 CSI    00000006@2015/3/17:21:38:28.336 (F) CMIADAPTER: Inner Error Message from AI HRESULT = HRESULT_FROM_WIN32(15010)
 [
[22]"Konfigurationsfehler

"
]
[gle=0x80004005]
2015-03-17 22:38:28, Error                 CSI    00000007@2015/3/17:21:38:28.336 (F) CMIADAPTER: AI failed. HRESULT = HRESULT_FROM_WIN32(15010)

The resolution to this problem is to:

  • Export and then delete the following registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WINEVT\Publishers{e7ef96be-969f-414f-97d7-3ddb7b558ccc}
  • Reboot the system
  • try to run Windows Update again.
  • Ok, thank you! I deleted the key; I rebooted, and verified it didn't re-appear; I started the update. After a few seconds, something seems to have been installed, but no entry in the updates history. Started again; now the 54 updates are being downloaded again (still "0 KB total, 0 % completed"); proceeding ... – Tobias Mar 18 '15 at 9:02
  • This has worked! – Tobias Mar 18 '15 at 9:48
  • nice to hear that it helped. – magicandre1981 Mar 18 '15 at 16:42
  • 1
    @Mr.Kennedy look in your CBS.log if you also see the line 00000002 (F) Logged @2015/3/17:21:38:28.321 : [ml:240{120},l:238{119}]"EventAITrace:Provider Microsoft-Windows-Win32k is already installed with GUID {e7ef96be-969f-414f-97d7-3ddb7b558ccc} if yes, delete this key. – magicandre1981 Feb 9 '17 at 16:15
  • 1
    @Mr.Kennedy in this case it is a different key. look in the log which issue you have – magicandre1981 Feb 9 '17 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.