I'm running Phabricator on AWS and pushing to git over http. If I push commits with large files the push will terminate with an EOF. Originally this was because there wasn't enough memory. I "fixed" this by adding a swap file. This worked but now I have to store some large log files for later. This time the swap is barely used, top isn't showing any processes that seem too large and I'm not seeing anything being terminated in dmesg. I've adjusted php (for the daemons) and apache memory settings but I must be missing something. Any ideas?

1 Answer 1


This kind of errors can be troubleshooted from your webserver logs, looking for the related error messages. But I can bet you reached an upload limit, so just can just increase these two dedicated PHP directives, to follow your needs:

Here it's explained how to increase them:


Anyway, using git over HTTP is not the best way to interact with your repositories. This is why Phabricator suggests to configure SSH support. SSH is more secure, more efficient, and without painful HTTP limits. The official guide covers this aspect:


Happy hacking!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .