0

I have a dual boot system with Ubuntu 14.04 and Windows 8.1. Until this moment everything worked fine, but just now when I tried to boot into Ubuntu I failed and I got this message:

Try(hd0,0): EXT2

On the other hand Windows boot just fine as it is proved by the fact that I am able to write this question!

What is happening? How can I fix that so to log into Ubuntu?

  • did you change anything in either OS immediately before this happened? Run any updates? – Russell Uhl Mar 18 '15 at 16:54
  • @RussellUhl I am not completely sure but I think that there was one update in Ubuntu....I need urgently to be able to at least access some files in that OS! – Adam Mar 18 '15 at 17:01
  • what happens if you boot into ubuntu, get that error, and then just sit there and wait for say, 5 minutes? (Obviously not the best solution, but give it a try. ubuntuforums.org/showthread.php?t=2012900) – Russell Uhl Mar 18 '15 at 17:04
  • @RussellUhl It just remains there saying this message. I didn't wait for 5 minutes but I think that is will just remain that way... – Adam Mar 18 '15 at 17:11
  • If it's urgent, boot from the Ubuntu 14.04 installation medium; you should be able to mount the disk[s] to access files, then repair later. – DrMoishe Pippik Mar 18 '15 at 23:41
0

I've had this issue last week and the answer to a similar question found here worked for me. The steps described there are these:

  • Use a live CD (Wubi will do too, escape while booting and choose Demo mode) to boot into a working Linux system.
  • Get the partition Linux is installed to with gparted (use this partition instead of /dev/sda1 in the next steps).
  • Mount the partition: sudo mount /dev/sda1 /mnt
  • Bind: sudo mount --bind /dev /mnt/dev && sudo mount --bind /dev/pts /mnt/dev/pts && sudo mount --bind /proc /mnt/proc && sudo mount --bind /sys /mnt/sys
  • sudo chroot /mnt
  • grub-install /dev/sda (sda not sda1, or other bootable disk)
  • grub-install --recheck /dev/sda
  • update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.