1

I have the following running on my Mac:

  • OSX Yosemite (10.10.2)
  • Java version 8 update 31
  • Safari 8.0.4

I am unable to run any Java applet on Safari. I have added multiple sites to the exception lists (in System Preferences -> Java Control Panel -> Security), but it has not changed anything.

I also don't see anything related to Java in Safari preferences:

enter image description here

When I try to run a Java applet, it says, Error. Click for details., and when I do, this is what I get:

enter image description here

I've tried Chrome and Firefox as well, and this is the common error they give me:

enter image description here

Whatever I do, I cannot allow for Java applets to be run on any browser.

  • Did you try adding 140.113.239.214 to the exception list under System Preferences -> Java -> Security ? – Erikster Mar 18 '15 at 23:12
  • Didn't work. It asked me permission to run it, I said ok, and then it didn't load again. It says Error, click for details again. But this time, the error is NullPointerException: There was an error while executing the application. Click "Details" for more information. – sodiumnitrate Mar 18 '15 at 23:42
  • 1
    Huh. NullPointerException sounds like an issue with the actual Java program you're trying to run. Do you have an IT group you can contact? – Erikster Mar 18 '15 at 23:44
  • Ok, tried it with another java applet from another site. It worked, but safari keeps on crashing. Works perfectly well with chrome, though. – sodiumnitrate Mar 19 '15 at 0:05
  • To Safari, Java counts as a plug-in. So you may need to click the "Website Settings…" button for plug-ins, find Java in the list of plug-ins, and add websites to the whitelist. – Spiff Mar 19 '15 at 0:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.