I upgraded Microsoft Remote Desktop Connection Manager from 2.2 to 2.7, but the new version DOES NOT SUPPORT DPI-Scaling anymore!

In version 2.2, you could define a fixed size for the remote server (e.g. 1920x1080), and then you could scale it to any client size you wanted. Therefore, on a 4K monitor, you had always had a very fine view of your server.

But now, in Version 2.7, I need a microscope to view my servers ;))

What happened? How can it be that a version of 2010 supports 4K monitors BETTER than a version from 2014 ???? Already the "Help->About" dialog is ill-scaled ! ;)

Has anyone a solution, other than going back to 2.2 ?

To clarify where to find this checkbox, go to the actual .exe file in C:\Program Files (x86)\Microsoft\Remote Desktop Connection Manager and right click the .exe file and click the Compatibility tab.O

2018 Windows 10 Update (1803/1809)

There are new cascading dialogs as shown below 2018 Compatibility tab DPI settings tab

  • 1
    Windows 10 (unsure which version - I have Creators Update) makes this a bit more complicated because there are now multiple modes under a checkbox named Override high DPI scaling behavior: Scaling performed by Application, System, or System (Enhanced). – Chris R. Donnelly May 12 '17 at 16:38

RDCMan.exe --> Properties --> uncheck “Disable display scaling on high DPI settings”.

On Windows 10 the dialog is slightly different.

Right click on the executable and choose Properties from the context menu. Swap to the Compatibility tab and clear the checkbox labelled 'Override high DPI scaling behavior.'.

enter image description here

protected by Community Mar 25 '17 at 5:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?