1

I have an HP Proliant Microserver (N40L with the 1.5GHz AMD dual core) at home that I have been using for a while as a source code repository and nightly build system. Being used that way didn't require a screen, just power and LAN.

I am busy re-doing the OS and adding some HDD space and an SSD drive to use as a compiler cache, and noticed something odd while attempting to install Ubuntu 14.04LTS.

When connected to a Samsung S20D300H 20 Inch LED Monitor, the POST screen, bios, boot menu all display fine. The moment the more graphical display of the Ubuntu installation process loads, the screen just goes black.

Initially I thought it was a problem with my boot drive, my RAM, even disconnected the SSD, but alas, no luck.

Eventually, several hours, cups of coffee, and lucky strikes later, I decided to just connect the screen I used to install Ubuntu 12.04LTS 2 years ago (an LG 20 inch CRT) AND IT WORKED. Tried the LED screen again, no luck.

So, does anybody have an idea why this would be the case, and/or a way to get around it? I don't have space for this LG CRT on my desk and would love to have this machine permanently hooked up to a monitor from now on.

Would a bios update, or perhaps allocating more memory for the on-board VGA controller help at all?

1

Turns out the VGA adapter (on-board) does not support my native screen resolution at 60Hz, and my monitor doesn't support it's own native resolution at 50Hz, which is all the VGA adapter is willing to output.

Problem can be solved by forcing a different display resolution from Grub, a safe bet is 1024x768, on grub command line options, add

vga=792

Sadly, I learned this after purchasing a low profile graphics card...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.