3

I have an instance of Ubuntu 14.04 LTS running on Google compute engine. I installed Cloudera manager on the instance and it is running administration web pages on localhost:7180. I am using port forwarding and xauth to access it from my laptop but it is really slow. Is there way I can directly access it by using an ip address from my browser. I tried doing http://A.B.C.D:7180 (A.B.C.D is my instance's external ip) in my browser but it's not working.

Thanks in advance. forgive me if my question is silly or too obvious.

5

As Bolwerk said you can try any of those methods but the easiest method is to enable local tunneling. Open your terminal and do this.

ssh -L 9999:localhost:7180 A.B.C.D

Now you will be logged into the server normally. Check whether the port 9999 is running any service. if you see 9999 there you are good to go.

netstat -tulpn

We don't need to configure any SOCKS proxy. Open any browser you like and type http://localhost:9999 and it will work like a charm. After you are done using close the terminal SSH session.

1

I don't know anything about Cloudera or Google Compute Engine's access limitations. You don't even say whether you have ssh. Here are a few things you can try...

Option 1

Assuming your laptop is Linux or BSD or maybe even Mac-based, you have SSH, need a GUI, and have SSH access on the server, you could create an ssh tunnel on your local machine. Open a terminal (xterm is fine) and run

ssh -D 8080 -C -N you@remote.machine

Do not close the terminal until you're done proxying!

Then open chromium with:

chromium --proxy-server="socks://localhost:8080"

If you don't have chromium, you'll need to configure socks manually (e.g., in Firefox). I use chromium only for this purpose and Firefox for nearly everything else.

You should be browsing as if you are local! http://localhost:7180 should work.

When done, ctrl+C out of the ssh tunnel you created or close the terminal.

Option 2

If the above is unworkable: assuming you have ssh and you can live with a text-based administration you could do

ssh -t remote.machine "lynx localhosthost:7180"

in an xterm. You may need to install lynx on Ubuntu.

Option 3

You may not be able to control the ports you have access to, but since it seems you have ssh access and the machine is yours to do with as you please, maybe install x2go. It's a pretty fast Linux remote desktop solution and it uses ssh.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.