i wonder if someone can help me - I've been asked by a friend to permanently disable the touchpad on her Acer Aspire 5175Z laptop.

There's a function key combo (Fn-F7) which disabled it but only until a reboot

The BIOS is incredibly basic and doesn't even mention input devices so no joy there

Windows XP won't allow you to disable a PS/2 mouse (which is how the touchpad is detected) even if you go through System>Hardware>Device Manager - The disable option simply isn;t there. I've tried uninstalling the driver but after the "suggested" reboot, the device is re-installed before she's past the welcome screen.

I've seen mention of a System tray app which achieves this but unfortunately, We've just had to rebuild her laptop from scratch so it's a stock XP Home install - So no tray icon for the mouse.

Can someone please point me in the right direction?

3 Answers 3


Instead of trying to brute-force kill the device -- check if you can install the driver package for the touchpad. It's likely you have either a Synaptics or Alps touchpad. In either case, the software has an option to disable the touchpad upon connecting an external mouse (haven't looked for an option that disables it for good though).

If that doesn't work out -- this is sort of a stretch, but maybe try changing the driver to something that "breaks" that device and prevents it from working? Like intentionally making it throw the yellow exclamation mark inside Device Manager.

Also, i8042prt is the driver that controls the PS/2 controller in general -- perhaps there's something you can do with that? I'm going to guess disabling it would be bad since that'll likely take out your keyboard too.

  • "I'm going to guess disabling it would be bad since that'll likely take out your keyboard too." yeah but it might be interesting :D Having just spent 7 hours rebuilding the bloody thing from scratch, I'm trying to be a little careful or I'd give it a go. Thanks for the suggestions - I'll give them a try :)
    – Basic
    Dec 30, 2009 at 1:23
  • managed to find the drivers here: drivers.synaptics.com/…
    – Basic
    Dec 30, 2009 at 1:52

If the user just wants to stop the touchpad from working while typing, there is an application that will do just that. Its called TouchFreeze, and is freely available. Check it out.



Following up the previously upvoted answer, tried to intentionally break the device driver from working normally.


1) Device manager > Mice and Pointing devices > PS/2 Compatible Mouse > Right Click and Select "Update Driver Software" > Browse My Computer for driver software > 'Let Me pick from a list of device drivers......."

2) Untick "Show Compatible hardware"

3) Select a driver other than "MICROSOFT : PS/2 Compatible Mouse"

4) Restart and DONE!!!!!

to revert back select the driver as "MICROSOFT : PS/2 Compatible Mouse" and restart :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .